libsimpa: Index des modules

  • Page principale
  • Modules
  • Espaces de nommage
  • Classes

Modules

Liste de tous les modules :
  • Ecriture d'un fichier de particule
  • Lecture d'un fichier de particule
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Ecriture d'un fichier de particule

  • Classes

Ecriture d'un fichier de particule

Fonctions

void | particleio::ParticuleIO::NewParticle (const unsigned long &firsttimestep)
void | particleio::ParticuleIO::NewPositionParticle (const float &x, const float &y, const float &z, const float &energy)
bool | particleio::ParticuleIO::OpenForWrite (const std::string &fileName)
void | particleio::ParticuleIO::SetHeaderData (const float &timeStep)

Description détaillée

Ces méthodes permettent de créer un nouveau fichier de particule

Documentation des fonctions

void particleio::ParticuleIO::NewParticle ( const unsigned long & firsttimestep ) [inherited]

Enregistre une nouvelle particule

void particleio::ParticuleIO::NewPositionParticle | ( | const float & | x,
 |  | const float & | y,
 |  | const float & | z,
 |  | const float & | energy |
 | ) |  |  | [inherited]

Enregistre une nouvelle position pour la particule courante

Paramètres:
x | Position
y | Position
z | Position
energy | Energie w
void particleio::ParticuleIO::SetHeaderData ( const float & timeStep ) [inherited]

Met à jour les données de l'entete du fichier

Paramètres:
timeStep Pas de temps en seconde
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Lecture d'un fichier de particule

  • Classes

Lecture d'un fichier de particule

Fonctions

void | particleio::ParticuleIO::GetHeaderData (float &timeStep, unsigned long &nbParticles, unsigned long &nbStepMax)
void | particleio::ParticuleIO::NextParticle (unsigned long &firstTimeStep, unsigned long &nbTimeStep)
void | particleio::ParticuleIO::NextTimeStep (float &x, float &y, float &z, float &energy)
bool | particleio::ParticuleIO::OpenForRead (const std::string &fileName)

Description détaillée

Ces méthodes permettent de lire un fichier de particule

Documentation des fonctions

void particleio::ParticuleIO::GetHeaderData | ( | float & | timeStep,
 |  | unsigned long & | nbParticles,
 |  | unsigned long & | nbStepMax |
 | ) |  |  | [inherited]

Permet d'accéder aux données d'entête du fichier de particule

Paramètres:
[out] | timeStep | Pas de temps en seconde
[out] | nbParticles | Nombre de particules
[out] | nbTimeStep | Nombre de particules
Python note:
Return a tuple containing (timeStep,nbParticles,nbStepMax)
void particleio::ParticuleIO::NextParticle | ( | unsigned long & | firstTimeStep,
 |  | unsigned long & | nbTimeStep |
 | ) |  |  | [inherited]

Passe à la prochaine particule

Paramètres:
[out] | firstTimeStep | Premier pas de temps
[out] | nbTimeStep | Nombre de pas de temps
Python note:
Return a tuple containing (firstTimeStep,nbTimeStep)
void particleio::ParticuleIO::NextTimeStep | ( | float & | x,
 |  | float & | y,
 |  | float & | z,
 |  | float & | energy |
 | ) |  |  | [inherited]

Lis une nouvelle position pour la particule courante

Paramètres:
[out] | x | Position
[out] | y | Position
[out] | z | Position
[out] | energy | Energie w
Python note:
Return a tuple containing (x,y,z,energy)
bool particleio::ParticuleIO::OpenForRead ( const std::string & fileName ) [inherited]

Lecture d'un fichier de particule

Paramètres:
fileName Chemin d'accès au fichier de particule
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des classes

  • Classes
  • Liste des classes
  • Membres de classe

Liste des classes

Liste des classes, structures, unions et interfaces avec une brève description :
formatMBIN::bintetraface | Structure d'une face d'un tetrahedre
formatMBIN::bintetrahedre | Structure d'un tétrahedre du maillage
CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique |
formatCoreBIN::CformatBIN | Classe de sauvegarde et de chargement de fichier de modèle entre l'interface et le mode de calcul SPPS
formatMBIN::CMBIN | Classe de sauvegarde et de chargement du maillage tétrahedrique
gabe_io::Gabe_rw |
formatCoreBIN::ioFace | Structure d'une face, déstiné à l'echange fichier<->CObjet3D
formatCoreBIN::ioModel | Structure du modèle, déstiné à l'echange fichier<->CObjet3D
particleio::ParticuleIO |
progressionInfo | Gestionnaire d'affichage de progression du calcul compatible avec le multithreading
progressOperation |
formatRSBIN::rsurf_data | Contient les données d'un fichier de résultat de récepteur de surfaces
formatRSBIN::rsurf_io |
formatRSBIN::rsurf_iso_contouring |
surf_merge::SurfaceMerging |
formatMBIN::t_binNode |
formatRSBIN::t_curve |
formatCoreBIN::t_pos |
formatMBIN::trimeshmodel |
volumes_splitter::VolumesSplitter |
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatMBIN::bintetraface

formatMBIN::bintetraface

Référence de la structure formatMBIN::bintetraface

Structure d'une face d'un tetrahedre. Plus de détails...

Liste de tous les membres

Attributs publics

Intb | marker
Intb | neighboor
Intb | sommets [3]

Description détaillée

Structure d'une face d'un tetrahedre.

Documentation des données membres

Intb formatMBIN::bintetraface::marker

Face du modèle -1 aucune

Intb formatMBIN::bintetraface::neighboor

Indice de tetraHedre 0 à n. -2 pour aucun voisin sur cette face

Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatMBIN::bintetrahedre

formatMBIN::bintetrahedre

Référence de la structure formatMBIN::bintetrahedre

Structure d'un tétrahedre du maillage. Plus de détails...

Graphe de collaboration de formatMBIN::bintetrahedre:
[légende]

Liste de tous les membres

Fonctions membres publiques

int | operator== (const bintetrahedre &_f)

Attributs publics

Intb | idVolume
Intb | sommets [4]
bintetraface | tetrafaces [4]

Description détaillée

Structure d'un tétrahedre du maillage.

Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique

CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique

Référence de la classe CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique

Liste de tous les membres

Fonctions membres publiques statiques

static double | c_son (double x)
static double | Coef_Att_Atmos (double F, double H, double P, double K)
static double | masse_vol (double P, double K)
Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatCoreBIN::CformatBIN

formatCoreBIN::CformatBIN

Référence de la classe formatCoreBIN::CformatBIN

Classe de sauvegarde et de chargement de fichier de modèle entre l'interface et le mode de calcul SPPS. Plus de détails...

Liste de tous les membres

Fonctions membres publiques

CformatBIN ()
bool | ExportBIN (const char *strFileName, ioModel &modelExport)
float | GetSurfAire (const ioModel &model, const int &indiceface)
bool | ImportBIN (ioModel &modelImport, const char *strFileName)
~CformatBIN ()

Description détaillée

Classe de sauvegarde et de chargement de fichier de modèle entre l'interface et le mode de calcul SPPS.

Voir également:
CObjet3D::Save()
CObjet3D::Load()

Documentation des constructeurs et destructeur

formatCoreBIN::CformatBIN::CformatBIN ( )

Constructeur

formatCoreBIN::CformatBIN::~CformatBIN ( )

Destructeur

Documentation des fonctions membres

bool formatCoreBIN::CformatBIN::ExportBIN | ( | const char * | strFileName,
 |  | ioModel & | modelExport
 | ) |  |

Méthode d'exportation d'un modèle 3D

Paramètres:
strFileName | Chemin du fichier
modelExport | Modèle à exporter, déjà converti par coordsOperation::GlCoordsToCommonCoords() .
matFacesAssociations | Lien entre les faces et les materiaux.
Renvoie:
Vrai si l'opération a réussi
float formatCoreBIN::CformatBIN::GetSurfAire | ( | const ioModel & | model,
 |  | const int & | indiceface
 | ) |  |

Retourne l'aire de la surface

bool formatCoreBIN::CformatBIN::ImportBIN | ( | ioModel & | modelImport,
 |  | const char * | strFileName
 | ) |  |

Méthode d'importation d'un fichier binaire

Paramètres:
modelImport | Structure de données où stocker le modèle à charger
strFileName | Chemin du fichier
Renvoie:
Vrai si l'opération a réussi
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatMBIN::CMBIN

formatMBIN::CMBIN

Référence de la classe formatMBIN::CMBIN

Classe de sauvegarde et de chargement du maillage tétrahedrique. Plus de détails...

Liste de tous les membres

Fonctions membres publiques

CMBIN ()
trimeshmodel | LoadMesh (const char *strFileName)
void | SaveMesh (const char *strFileName, trimeshmodel &trimesh)
~CMBIN ()

Fonctions membres publiques statiques

static double | ComputeVolume (trimeshmodel &trimesh)

Description détaillée

Classe de sauvegarde et de chargement du maillage tétrahedrique.

Documentation des constructeurs et destructeur

formatMBIN::CMBIN::CMBIN ( ) [inline]

Constructeur

formatMBIN::CMBIN::~CMBIN ( ) [inline]

Destructeur

Documentation des fonctions membres

trimeshmodel formatMBIN::CMBIN::LoadMesh ( const char * strFileName )

Méthode d'importation d'un fichier binaire

Paramètres:
strFileName Chemin du fichier
Renvoie:
Le maillage
void formatMBIN::CMBIN::SaveMesh | ( | const char * | strFileName,
 |  | trimeshmodel & | trimesh
 | ) |  |

Méthode d'exportation d'un fichier binaire

Paramètres:
strFileName | Chemin du fichier
trimesh | Le maillage
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe gabe_io::Gabe_rw

gabe_io::Gabe_rw

Référence de la classe gabe_io::Gabe_rw

Liste de tous les membres

Fonctions membres publiques

void | AppendFloatCol (const floatarray &coldata, const string &coltitle, const int &precision=12)
void | AppendIntCol (const intarray &coldata, const string &coltitle)
void | AppendStrCol (const stringarray &coldata, const string &coltitle)
Gabe_rw (const size_t &sizeHint)
string | GetColTitle (const size_t &idcol)
typearray | GetTabTypes ()
bool | IsReadOnly ()
bool | Load (const string &fileName)
stringarray | operator[] (size_t indicecol)
void | ReadColFloat (const size_t &idcol, floatarray &coldata)
void | ReadColInt (const size_t &idcol, intarray &coldata)
void | ReadColStr (const size_t &idcol, stringarray &coldata)
bool | Save (const string &fileName)
void | SetReadOnly (const bool &ReadOnly=true)
size_t | size () const

Description détaillée

Gestion d'écriture et de lecture du format GABE lu par l'interface La première colonne correspond aux libellées des lignes. Chaque colonne peut être de 3 types différends, chaine de caractère, nombre à décimale ou nombre entier.

Documentation des constructeurs et destructeur

gabe_io::Gabe_rw::Gabe_rw ( const size_t & sizeHint )
Paramètres:
sizeHint A la génération d'un tableau ce paramètre permet une plus grand rapiditée d'ajout des colonnes

Documentation des fonctions membres

void gabe_io::Gabe_rw::AppendFloatCol | ( | const floatarray & | coldata,
 |  | const string & | coltitle,
 |  | const int & | precision = 12
 | ) |  |

Ajoute une colonne de nombres flottants à la fin du tableau

void gabe_io::Gabe_rw::AppendIntCol | ( | const intarray & | coldata,
 |  | const string & | coltitle
 | ) |  |

Ajoute une colonne d'entier à la fin du tableau

void gabe_io::Gabe_rw::AppendStrCol | ( | const stringarray & | coldata,
 |  | const string & | coltitle
 | ) |  |

Ajoute une colonne de chaine de caractères à la fin du tableau

string gabe_io::Gabe_rw::GetColTitle ( const size_t & idcol )

Lecture du titre d'une colonne

typearray gabe_io::Gabe_rw::GetTabTypes ( )

Retourne les types de données sur les colonnes

bool gabe_io::Gabe_rw::IsReadOnly ( )

Les données sont elles en lecture seule pour l'utilisateur.

bool gabe_io::Gabe_rw::Load ( const string & fileName )

Chargement du tableau

Paramètres:
strFileName Chemin du fichier
stringarray gabe_io::Gabe_rw::operator[] ( size_t indicecol )

Lire une colonne en tant que chaine de caractères (compatible avec n'importe quel type de colonne)

bool gabe_io::Gabe_rw::Save ( const string & fileName )

Sauvegarde du tableau

Paramètres:
strFileName Chemin du fichier
void gabe_io::Gabe_rw::SetReadOnly ( const bool & ReadOnly = true )

Change le mode d'édition par l'utilisateur dans l'interface

size_t gabe_io::Gabe_rw::size ( ) const
Renvoie:
Nombre de colonnes
Python note:
Use the len function to give the number of cols.
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatCoreBIN::ioFace

formatCoreBIN::ioFace

Référence de la structure formatCoreBIN::ioFace

Structure d'une face, déstiné à l'echange fichier<->CObjet3D. Plus de détails...

Liste de tous les membres

Fonctions membres publiques

int | operator== (const ioFace &_f)

Attributs publics

indiceV | a
indiceV | b
indiceV | c
indiceEN | idEn
indiceMat | idMat
indiceRS | idRs

Description détaillée

Structure d'une face, déstiné à l'echange fichier<->CObjet3D.

Documentation des données membres

indiceV formatCoreBIN::ioFace::a

Indice du sommet

indiceV formatCoreBIN::ioFace::b

Indice du sommet

indiceV formatCoreBIN::ioFace::c

Indice du sommet

indiceEN formatCoreBIN::ioFace::idEn

Identifiant de l'encombrement (aucun -1)

indiceMat formatCoreBIN::ioFace::idMat

Identifiant du matériau associé à la face (aucun 0)

indiceRS formatCoreBIN::ioFace::idRs

Identifiant du récepteur surfacique (aucun -1)

Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatCoreBIN::ioModel

formatCoreBIN::ioModel

Référence de la structure formatCoreBIN::ioModel

Structure du modèle, déstiné à l'echange fichier<->CObjet3D. Plus de détails...

Liste de tous les membres

Attributs publics

std::vector< ioFace > | faces
std::vector< t_pos > | vertices

Description détaillée

Structure du modèle, déstiné à l'echange fichier<->CObjet3D.

Documentation des données membres

std::vector<ioFace> formatCoreBIN::ioModel::faces

Faces de la scène

std::vector<t_pos> formatCoreBIN::ioModel::vertices

Sommets des triangles

Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe particleio::ParticuleIO

particleio::ParticuleIO

Référence de la classe particleio::ParticuleIO

Graphe de collaboration de particleio::ParticuleIO:
[légende]

Liste de tous les membres

Classes

struct | currentPartInfo_t
struct | fileInfo_t

Fonctions membres publiques

void | Close ()
void | GetHeaderData (float &timeStep, unsigned long &nbParticles, unsigned long &nbStepMax)
void | NewParticle (const unsigned long &firsttimestep)
void | NewPositionParticle (const float &x, const float &y, const float &z, const float &energy)
void | NextParticle (unsigned long &firstTimeStep, unsigned long &nbTimeStep)
void | NextTimeStep (float &x, float &y, float &z, float &energy)
bool | OpenForRead (const std::string &fileName)
bool | OpenForWrite (const std::string &fileName)
void | SetHeaderData (const float &timeStep)

Description détaillée

Cette classe permet la gestion du fichier d'enregistrement de la propagation des particules Les données sont consérvés uniquement sur le disque durant toute la procédure d'écriture et de lecture car ce type de fichier pouvant être trés volumineux.

Documentation des fonctions membres

void particleio::ParticuleIO::Close ( )

Fermeture du fichier Cette méthode est automatiquement appelé lors de la destruction de l'instance de ParticuleIO

Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe progressionInfo

Référence de la classe progressionInfo

Gestionnaire d'affichage de progression du calcul compatible avec le multithreading. Plus de détails...

Graphe de collaboration de progressionInfo:
[légende]

Liste de tous les membres

Fonctions membres publiques

float | GetCurrentProgression ()
progressOperation * GetMainOperation ()
void | OutputCurrentProgression ()
progressionInfo (int firstLevelEstimation)

Fonctions membres protégées

virtual void | DoShowProgression (float newProg)

Description détaillée

Gestionnaire d'affichage de progression du calcul compatible avec le multithreading.

Documentation des constructeurs et destructeur

progressionInfo::progressionInfo ( int firstLevelEstimation ) [inline]

Constructeur

Paramètres:
firstLevelEstimation Nombre de tache au premier niveau hiérarchique de taches

Documentation des fonctions membres

progressOperation* progressionInfo::GetMainOperation ( ) [inline]
Renvoie:
L'operation principale.
void progressionInfo::OutputCurrentProgression ( ) [inline]

Affiche la progression si celle-ci a changé

Généré le Fri Jan 29 11:31:39 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe progressOperation

Référence de la classe progressOperation

Graphe de collaboration de progressOperation:
[légende]

Liste de tous les membres

Fonctions membres publiques

void | GetState (float *thisLvlProg)
progressOperation (progressOperation *parentOperation, unsigned int sonEstimation=1)

Fonctions membres protégées

void | PushProgression (float incProg)

Description détaillée

Représente une opération de calcul

Documentation des constructeurs et destructeur

progressOperation::progressOperation | ( | progressOperation * | parentOperation,
 |  | unsigned int | sonEstimation = 1 |
 | ) |  |  | [inline]

Constructeur

Documentation des fonctions membres

void progressOperation::PushProgression ( float incProg ) [inline, protected]

Un des fils a changé d'état incProg constitue la différence entre la dernière mise à jour de sa progression et sa nouvelle progression

Paramètres:
incProg ]0;1]
Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatRSBIN::rsurf_data

formatRSBIN::rsurf_data

Référence de la classe formatRSBIN::rsurf_data

Contient les données d'un fichier de résultat de récepteur de surfaces. Plus de détails...

Liste de tous les membres

Fonctions membres publiques

void | GetFaceEnergy (const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &recordIndex, std::size_t &idstep, float &energy) const
void | GetFaceInfo (const std::size_t &rsIndex, const std::size_t &faceIndex, std::size_t &vertexA, std::size_t &vertexB, std::size_t &vertexC, std::size_t &recordCount) const
float | GetFaceSumEnergy (const std::size_t &rsIndex, const std::size_t &faceIndex)
void | GetFileInfos (std::size_t &rs_size, std::size_t &nodes_size, std::size_t &nbtimestep, float &timestep, std::string &recordType) const
void | GetNodePositionValue (const std::size_t &nodeIndex, float &x, float &y, float &z) const
std::size_t | GetRsCount ()
void | GetRsInfo (const std::size_t &rsIndex, std::size_t &nbfaces, std::string &rs_name, int &xmlid) const
void | Make (const std::size_t &tabNodesSize, const std::size_t &tabRsSize, const int &nbtimestep, const float &timestep, const std::string &record_type="SPL_STANDART")
void | MakeRs (const std::size_t &rsIndex, const std::size_t &nbfacesconst, const std::string &rs_name, const int &xmlid)
void | SetFaceEnergy (const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &recordIndex, const std::size_t &idstep, const float &energy)
void | SetFaceInfo (const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &vertexA, const std::size_t &vertexB, const std::size_t &vertexC, const std::size_t &recordCount)
void | SetNodeValue (const std::size_t &nodeIndex, const float &x, const float &y, const float &z)
void | SetRsBinData (t_ExchangeData &rsData)
void | SetRsBinData (t_ExchangeData *rsData)

Fonctions membres protégées

t_ExchangeData * | GetStruct ()
void | SetStruct (t_ExchangeData *extData)

Description détaillée

Contient les données d'un fichier de résultat de récepteur de surfaces.

Permet de créer et de lire les données

Documentation des fonctions membres

void formatRSBIN::rsurf_data::GetFaceEnergy | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | faceIndex,
 |  | const std::size_t & | recordIndex,
 |  | std::size_t & | idstep,
 |  | float & | energy |
 | ) |  |  | const

Accesseur Information sur un enregistrement d'une face

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[in] | faceIndex | Indice de la surface
[in] | recordIndex | Indice de l'enregistrement
[out] | idstep | Compteur du pas de temps
[out] | energy | Energie(w) ou temps(s)
Python note:
Return a tuple containing (idstep,energy)
void formatRSBIN::rsurf_data::GetFaceInfo | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | faceIndex,
 |  | std::size_t & | vertexA,
 |  | std::size_t & | vertexB,
 |  | std::size_t & | vertexC,
 |  | std::size_t & | recordCount |
 | ) |  |  | const

Accesseur Information sur une face

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[in] | faceIndex | Indice de la surface
[out] | vertexA | Indice du sommet
[out] | vertexB | Indice du sommet
[out] | vertexC | Indice du sommet
[out] | recordCount | Nombre d'enregistrement
Python note:
Return a tuple containing ( vertexA,vertexB,vertexC,recordCount)
float formatRSBIN::rsurf_data::GetFaceSumEnergy | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | faceIndex
 | ) |  |

Accesseur Information sur un enregistrement d'une face

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[in] | faceIndex | Indice de la surface
Renvoie:
Energie cumulé (w) ou temps (s)
void formatRSBIN::rsurf_data::GetFileInfos | ( | std::size_t & | rs_size,
 |  | std::size_t & | nodes_size,
 |  | std::size_t & | nbtimestep,
 |  | float & | timestep,
 |  | std::string & | recordType |
 | ) |  |  | const

Accesseur propriétés du fichier

Paramètres:
[out] | rs_size | Nombre de sommets de triangles
[out] | nodes_size | Nombre de récepteurs de surfaces
[out] | nbtimestep | Nombre de pas de temps maximum
[out] | timestep | Pas de temps en secondes
[out] | record_type | Type d'enregistrement. Valeurs possibles "SPL_STANDART" "SPL_GAIN" "TR" "EDT"
Python note:
Return a tuple containing (rs_size,nodes_size,nbtimestep,timestep,recordType)
void formatRSBIN::rsurf_data::GetNodePositionValue | ( | const std::size_t & | nodeIndex,
 |  | float & | x,
 |  | float & | y,
 |  | float & | z |
 | ) |  |  | const

Accesseur valeur d'un noeud

Paramètres:
[in] | nodeIndex | Indice du sommet
[out] | x | X
[out] | y | Y
[out] | z | Z
Python note:
Return a tuple containing (x,y,z)
std::size_t formatRSBIN::rsurf_data::GetRsCount ( )
Renvoie:
le nombre de récepteur surfaciques.
void formatRSBIN::rsurf_data::GetRsInfo | ( | const std::size_t & | rsIndex,
 |  | std::size_t & | nbfaces,
 |  | std::string & | rs_name,
 |  | int & | xmlid |
 | ) |  |  | const

Accesseur Information sur un recepteur surfacique

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[out] | nbfaces | Nombre de surfaces
[out] | rs_name | Libellé du récepteur de surface
[out] | xmlid | Indice xml du récepteur
Python note:
Return a tuple containing (nbfaces,rs_name,xmlid)
void formatRSBIN::rsurf_data::Make | ( | const std::size_t & | tabNodesSize,
 |  | const std::size_t & | tabRsSize,
 |  | const int & | nbtimestep,
 |  | const float & | timestep,
 |  | const std::string & | record_type = "SPL_STANDART"
 | ) |  |

1ere étape Création, Mise en place des récepteurs et des propriétés

Paramètres:
[in] | tabNodesSize | Nombre de sommets de triangles
[in] | tabRsSize | Nombre de récepteurs de surfaces
[in] | nbtimestep | Nombre de pas de temps maximum
[in] | timestep | Pas de temps en secondes
[in] | record_type | Type d'enregistrement. Valeurs possibles "SPL_STANDART" "SPL_GAIN" "TR" "EDT"
void formatRSBIN::rsurf_data::MakeRs | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | nbfacesconst,
 |  | const std::string & | rs_name,
 |  | const int & | xmlid
 | ) |  |

2eme étape Création, Affectation des propriétés d'un récepteur

Paramètres:
[in] | rsIndex | Indice du récepteur surfacique
[in] | nbfacesconst | Nombre de faces dans ce récepteur de surfaces.
[in] | rs_name | Nom du récepteur de surface
[in] | xmlid | Indice XML du récepteur de surface
void formatRSBIN::rsurf_data::SetFaceEnergy | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | faceIndex,
 |  | const std::size_t & | recordIndex,
 |  | const std::size_t & | idstep,
 |  | const float & | energy
 | ) |  |

4eme étape Création, Affectation de la valeur de pression d'un pas de temps sur une face

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[in] | faceIndex | Indice de la face
[in] | recordIndex | Indice de l'enregistrement
[in] | idstep | xeme pas de temps ( x=y sec/timestep )
[in] | energy | Niveau de pression (SPL) ou temps (TR EDT)
void formatRSBIN::rsurf_data::SetFaceInfo | ( | const std::size_t & | rsIndex,
 |  | const std::size_t & | faceIndex,
 |  | const std::size_t & | vertexA,
 |  | const std::size_t & | vertexB,
 |  | const std::size_t & | vertexC,
 |  | const std::size_t & | recordCount
 | ) |  |

3eme étape Création, Affectation des propriétés d'une face

Paramètres:
[in] | rsIndex | Indice du récepteur de surface
[in] | faceIndex | Indice de la face
[in] | vertexA | Indice du sommet
[in] | vertexB | Indice du sommet
[in] | vertexC | Indice du sommet
[in] | recordCount | Nombre d'enregistrements de niveaux (energy!=0)
void formatRSBIN::rsurf_data::SetNodeValue | ( | const std::size_t & | nodeIndex,
 |  | const float & | x,
 |  | const float & | y,
 |  | const float & | z
 | ) |  |

2eme étape Création, Affectation de la valeur d'un noeud

Paramètres:
[in] | nodeIndex | Indice du sommet
[in] | x | Position X (m)
[in] | y | Position Y (m)
[in] | z | Position Z (m)
void formatRSBIN::rsurf_data::SetRsBinData ( t_ExchangeData * rsData )

Affecte directement les données à cette classe à partir de la structure correspondance.

Avertissement:
Cette classe supprimera ces données, à moins que NULL soit passé en parémètre avant la suppression de rsurf_data
Python note:
Non disponible en python
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatRSBIN::rsurf_io

formatRSBIN::rsurf_io

Référence de la classe formatRSBIN::rsurf_io

Liste de tous les membres

Fonctions membres publiques statiques

static bool | Load (const std::string &fileName, rsurf_data &data)
static bool | Save (const std::string &fileName, rsurf_data &data)
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatRSBIN::rsurf_iso_contouring

formatRSBIN::rsurf_iso_contouring

Référence de la classe formatRSBIN::rsurf_iso_contouring

Liste de tous les membres

Fonctions membres publiques

void | GetIsoLevelCurves (const float &isolvl, std::list< t_curve > &curvlst)
void | GetMinMax (float &min, float &max)
rsurf_iso_contouring (const rsurf_data &data, const std::size_t &rsIndex)
void | SmoothGrid (const int &smoothcount)

Documentation des constructeurs et destructeur

formatRSBIN::rsurf_iso_contouring::rsurf_iso_contouring | ( | const rsurf_data & | data,
 |  | const std::size_t & | rsIndex
 | ) |  |

/~english Iso Contouring initialisation step.

Documentation des fonctions membres

void formatRSBIN::rsurf_iso_contouring::GetIsoLevelCurves | ( | const float & | isolvl,
 |  | std::list< t_curve > & | curvlst
 | ) |  |

Calcul la position de segments

void formatRSBIN::rsurf_iso_contouring::GetMinMax | ( | float & | min,
 |  | float & | max
 | ) |  |

Retourne les valeurs min,max

void formatRSBIN::rsurf_iso_contouring::SmoothGrid ( const int & smoothcount )

Afin de lisser les isocourbes on peut multiplier le nombre de triangle et interpoler la valeur des nouveaux sommets.

Paramètres:
smoothcount Nombre de subdivision de la grille.
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe surf_merge::SurfaceMerging

surf_merge::SurfaceMerging

Référence de la classe surf_merge::SurfaceMerging

Liste de tous les membres

Fonctions membres publiques

void | GetGroupInformation (const int &idel, std::vector< std::size_t > &faceIds)
int | GetGroups ()
void | LoadGroups (const formatCoreBIN::ioModel &model)
void | SavePolyToPolyFile (const char *strFileName)

Description détaillée

Regrouper les faces selon la même norme et le même matériau

Permet de regrouper les faces selon la même norme et le même matériau

Documentation des fonctions membres

void surf_merge::SurfaceMerging::GetGroupInformation | ( | const int & | idel,
 |  | std::vector< std::size_t > & | faceIds
 | ) |  |

Donne les données pour un groupe

Paramètres:
[in] | idel | Indice du groupe [0-GetGroups()[
[out] | faceIds | Faces du groupe
Python note:
Return faceIds vector, use list(SurfaceMerging::GetGroupInformation(idel)) python built-in function to translate into an integer list.
int surf_merge::SurfaceMerging::GetGroups ( )

Retourne le nombre de groupes de surfaces détectés

void surf_merge::SurfaceMerging::LoadGroups ( const formatCoreBIN::ioModel & model )

Lectures des structures de données à la recherche des faces coplanaires

Paramètres:
model Modèle de la scène
void surf_merge::SurfaceMerging::SavePolyToPolyFile ( const char * strFileName )

Sauvegarde les triangles fusionnés dans le format de fichier .poly

Paramètres:
strFileName Nom et chemin du fichier de sortie
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatMBIN::t_binNode

formatMBIN::t_binNode

Référence de la structure formatMBIN::t_binNode

Liste de tous les membres

Fonctions membres publiques

int | operator== (const t_binNode &_f)
t_binNode (const Floatb &x, const Floatb &y, const Floatb &z)

Attributs publics

Floatb | node [3]
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatRSBIN::t_curve

formatRSBIN::t_curve

Référence de la structure formatRSBIN::t_curve

Liste de tous les membres

Attributs publics

t_pos | A
t_pos | B
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe formatCoreBIN::t_pos

formatCoreBIN::t_pos

Référence de la classe formatCoreBIN::t_pos

Liste de tous les membres

Fonctions membres publiques

operator float * ()
int | operator== (const t_pos &_v)
const float & | operator[] (int _i) const
t_pos (float _x, float _y, float _z)

Attributs publics

union {
struct {
float x
float y
float z
}
float v [3]
};
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la structure formatMBIN::trimeshmodel

formatMBIN::trimeshmodel

Référence de la structure formatMBIN::trimeshmodel

Liste de tous les membres

Attributs publics

std::vector< t_binNode > | nodes
std::vector< bintetrahedre > | tetrahedres
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de la classe volumes_splitter::VolumesSplitter

volumes_splitter::VolumesSplitter

Référence de la classe volumes_splitter::VolumesSplitter

Liste de tous les membres

Classes

struct | facemodel_t
struct | vol_t

Fonctions membres publiques

void | GetInternalFaces (std::vector< std::size_t > &internalFaceIds, const int &volumeXmlIdFilter=-1)
int | GetTetraByPosition (const formatMBIN::trimeshmodel &tetramodel, const float &x, const float &y, const float &z, const bool &reloadTetraModel=false)
void | GetVolumeInformation (const int &idel, int &volumeXmlId, double &volume, std::vector< std::size_t > &faceIds, std::vector< std::size_t > &volNeigh)
int | GetVolumes ()
int | GetVolumeXmlId (const int &idel)
void | LoadDomain (const formatCoreBIN::ioModel &model, const formatMBIN::trimeshmodel &tetramodel)

Description détaillée

Séparation d'un modèle en volumes

Cette classe permet de regrouper les faces par rapport aux volumes auxquels ils appartiennent

Documentation des fonctions membres

void volumes_splitter::VolumesSplitter::GetInternalFaces | ( | std::vector< std::size_t > & | internalFaceIds,
 |  | const int & | volumeXmlIdFilter = -1
 | ) |  |

Retourne la liste des limites internes (faces ayant un volume de chaque coté

Paramètres:
[out] | internalFaceIds | Faces propre au volume
int] | volumeXmlIdFilter Limiter les faces internes appartenant à ce volume (-1 aucun filtre)
Python note:
Return internalFaceIds
int volumes_splitter::VolumesSplitter::GetTetraByPosition | ( | const formatMBIN::trimeshmodel & | tetramodel,
 |  | const float & | x,
 |  | const float & | y,
 |  | const float & | z,
 |  | const bool & | reloadTetraModel = false
 | ) |  |

Cherche la tétraèdre contenant le point indiqué en paramètre.

Avertissement:
Il n'est pas nécessaire d'appeler la méthode LoadDomain avant d'utiliser cette fonction
Paramètres:
tetramodel | Maillage de la scène
x | Position
y | Position
z | Position
reloadTetraModel | Recharge le premier paramètre dans la table de test de position. Mettez le à vrai si vous avez modifié la structure tetramodel entre deux appel de GetTetraByPosition.
Renvoie:
L'indice du tetraèdre ou -1 si non trouvé.
void volumes_splitter::VolumesSplitter::GetVolumeInformation | ( | const int & | idel,
 |  | int & | volumeXmlId,
 |  | double & | volume,
 |  | std::vector< std::size_t > & | faceIds,
 |  | std::vector< std::size_t > & | volNeigh
 | ) |  |

Donne les données pour un volume

Paramètres:
[in] | idel | Indice du volume [0-GetVolumes()[
[out] | volumeXmlId | Indice Xml du volume
[out] | volume | Volume (m3)
[out] | faceIds | Faces propre au volume
[out] | volNeigh | Volumes voisins du volume idel
Python note:
Read through VolumesSplitterInstance[volid] and return a tuple containing (volumeXmlId,volume,faceIds,volNeigh)
int volumes_splitter::VolumesSplitter::GetVolumes ( ) [inline]

Retourne le nombre de volumes détectés

Python note:
Read through len(VolumesSplitterInstance)
int volumes_splitter::VolumesSplitter::GetVolumeXmlId ( const int & idel )

Donne l'Indice Xml du volume

Paramètres:
[in] idel Indice du volume [0-GetVolumes()[
Renvoie:
Indice Xml du volume
void volumes_splitter::VolumesSplitter::LoadDomain | ( | const formatCoreBIN::ioModel & | model,
 |  | const formatMBIN::trimeshmodel & | tetramodel
 | ) |  |

Lectures des structures de données à la recherche des volumes

Paramètres:
model | Modèle de la scène
tetramodel | Maillage de la scène
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Membres de classe

  • Tout
  • Fonctions
  • Variables
  • a
  • b
  • c
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • v
  • ~
Liste de tous les membres de classe documentés avec liens vers la documentation de classe de chaque membre :

- a -

  • a : formatCoreBIN::ioFace
  • AppendFloatCol() : gabe_io::Gabe_rw
  • AppendIntCol() : gabe_io::Gabe_rw
  • AppendStrCol() : gabe_io::Gabe_rw

- b -

  • b : formatCoreBIN::ioFace

- c -

  • c : formatCoreBIN::ioFace
  • CformatBIN() : formatCoreBIN::CformatBIN
  • Close() : particleio::ParticuleIO
  • CMBIN() : formatMBIN::CMBIN

- e -

  • ExportBIN() : formatCoreBIN::CformatBIN

- f -

  • faces : formatCoreBIN::ioModel

- g -

  • Gabe_rw() : gabe_io::Gabe_rw
  • GetColTitle() : gabe_io::Gabe_rw
  • GetFaceEnergy() : formatRSBIN::rsurf_data
  • GetFaceInfo() : formatRSBIN::rsurf_data
  • GetFaceSumEnergy() : formatRSBIN::rsurf_data
  • GetFileInfos() : formatRSBIN::rsurf_data
  • GetGroupInformation() : surf_merge::SurfaceMerging
  • GetGroups() : surf_merge::SurfaceMerging
  • GetHeaderData() : particleio::ParticuleIO
  • GetInternalFaces() : volumes_splitter::VolumesSplitter
  • GetIsoLevelCurves() : formatRSBIN::rsurf_iso_contouring
  • GetMainOperation() : progressionInfo
  • GetMinMax() : formatRSBIN::rsurf_iso_contouring
  • GetNodePositionValue() : formatRSBIN::rsurf_data
  • GetRsCount() : formatRSBIN::rsurf_data
  • GetRsInfo() : formatRSBIN::rsurf_data
  • GetSurfAire() : formatCoreBIN::CformatBIN
  • GetTabTypes() : gabe_io::Gabe_rw
  • GetTetraByPosition() : volumes_splitter::VolumesSplitter
  • GetVolumeInformation() : volumes_splitter::VolumesSplitter
  • GetVolumes() : volumes_splitter::VolumesSplitter
  • GetVolumeXmlId() : volumes_splitter::VolumesSplitter

- i -

  • idEn : formatCoreBIN::ioFace
  • idMat : formatCoreBIN::ioFace
  • idRs : formatCoreBIN::ioFace
  • ImportBIN() : formatCoreBIN::CformatBIN
  • IsReadOnly() : gabe_io::Gabe_rw

- l -

  • Load() : gabe_io::Gabe_rw
  • LoadDomain() : volumes_splitter::VolumesSplitter
  • LoadGroups() : surf_merge::SurfaceMerging
  • LoadMesh() : formatMBIN::CMBIN

- m -

  • Make() : formatRSBIN::rsurf_data
  • MakeRs() : formatRSBIN::rsurf_data
  • marker : formatMBIN::bintetraface

- n -

  • neighboor : formatMBIN::bintetraface
  • NewParticle() : particleio::ParticuleIO
  • NewPositionParticle() : particleio::ParticuleIO
  • NextParticle() : particleio::ParticuleIO
  • NextTimeStep() : particleio::ParticuleIO

- o -

  • OpenForRead() : particleio::ParticuleIO
  • operator[]() : gabe_io::Gabe_rw
  • OutputCurrentProgression() : progressionInfo

- p -

  • progressionInfo() : progressionInfo
  • progressOperation() : progressOperation
  • PushProgression() : progressOperation

- r -

  • rsurf_iso_contouring() : formatRSBIN::rsurf_iso_contouring

- s -

  • Save() : gabe_io::Gabe_rw
  • SaveMesh() : formatMBIN::CMBIN
  • SavePolyToPolyFile() : surf_merge::SurfaceMerging
  • SetFaceEnergy() : formatRSBIN::rsurf_data
  • SetFaceInfo() : formatRSBIN::rsurf_data
  • SetHeaderData() : particleio::ParticuleIO
  • SetNodeValue() : formatRSBIN::rsurf_data
  • SetReadOnly() : gabe_io::Gabe_rw
  • SetRsBinData() : formatRSBIN::rsurf_data
  • size() : gabe_io::Gabe_rw
  • SmoothGrid() : formatRSBIN::rsurf_iso_contouring

- v -

  • vertices : formatCoreBIN::ioModel

- ~ -

  • ~CformatBIN() : formatCoreBIN::CformatBIN
  • ~CMBIN() : formatMBIN::CMBIN
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Index des espaces de nommage

  • Liste des espaces de nommage

Liste des espaces de nommage

Liste de tous les espaces de nommage documentés avec une brève description:
CalculsGenerauxThermodynamique | Calculs de theromodynamique
formatCoreBIN | Implémentation de l'interpréteur de fichier modèle Bin (*.bin)
formatMBIN | Import export du maillage tétrahedrique
formatRSBIN | Import export de l'animation des recepteurs surfaciques
gabe_io | Fichier d'échange générique
particleio | Lecture, ecriture des fichiers de particules
surf_merge |
Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage CalculsGenerauxThermodynamique

  • Liste des espaces de nommage

Référence de l'espace de nommage CalculsGenerauxThermodynamique

Calculs de theromodynamique. Plus de détails...

Classes

class CCalculsGenerauxThermodynamique

Description détaillée

Calculs de theromodynamique.

Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage formatCoreBIN

  • Liste des espaces de nommage

Référence de l'espace de nommage formatCoreBIN

Implémentation de l'interpréteur de fichier modèle Bin (*.bin). Plus de détails...

Classes

class | CformatBIN
Classe de sauvegarde et de chargement de fichier de modèle entre l'interface et le mode de calcul SPPS. Plus de détails...
struct | ioFace
Structure d'une face, déstiné à l'echange fichier<->CObjet3D. Plus de détails...
struct | ioModel
Structure du modèle, déstiné à l'echange fichier<->CObjet3D. Plus de détails...
class | t_pos

Description détaillée

Implémentation de l'interpréteur de fichier modèle Bin (*.bin).

Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage formatMBIN

  • Liste des espaces de nommage

Référence de l'espace de nommage formatMBIN

Import export du maillage tétrahedrique. Plus de détails...

Classes

struct | bintetraface
Structure d'une face d'un tetrahedre. Plus de détails...
struct | bintetrahedre
Structure d'un tétrahedre du maillage. Plus de détails...
class | CMBIN
Classe de sauvegarde et de chargement du maillage tétrahedrique. Plus de détails...
struct | t_binNode
struct | trimeshmodel

Définition de type

typedef unsigned short | bCourt
typedef bool | Boolb
typedef float | Floatb
typedef int | Intb
typedef unsigned long | Longb

Description détaillée

Import export du maillage tétrahedrique.

Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage formatRSBIN

  • Liste des espaces de nommage

Référence de l'espace de nommage formatRSBIN

Import export de l'animation des recepteurs surfaciques. Plus de détails...

Classes

class | rsurf_data
Contient les données d'un fichier de résultat de récepteur de surfaces. Plus de détails...
class | rsurf_io
class | rsurf_iso_contouring
struct | t_curve

Définition de type

typedef std::size_t | t_index [3]
typedef float | t_pos [3]

Description détaillée

Import export de l'animation des recepteurs surfaciques.

Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage gabe_io

  • Liste des espaces de nommage

Référence de l'espace de nommage gabe_io

Fichier d'échange générique. Plus de détails...

Classes

class | Gabe_rw

Définition de type

typedef formatGABE::GABE_OBJECTTYPE | COLTYPE
typedef vector< float > | floatarray
typedef vector< int > | intarray
typedef vector< string > | stringarray
typedef vector< COLTYPE > | typearray

Fonctions

static void | impl_vectors ()

Description détaillée

Fichier d'échange générique.

Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage particleio

  • Liste des espaces de nommage

Référence de l'espace de nommage particleio

Lecture, ecriture des fichiers de particules. Plus de détails...

Classes

class ParticuleIO

Description détaillée

Lecture, ecriture des fichiers de particules.

Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Référence de l'espace de nommage surf_merge

  • Liste des espaces de nommage

Référence de l'espace de nommage surf_merge

Classes

class SurfaceMerging

Description détaillée

Permet de regrouper les faces selon la même norme et le même matériau

Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique Liste des membres

Liste complète des membres de CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique, y compris les membres hérités :
c_son(double x) (défini dans CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique) | CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique | [static]
Coef_Att_Atmos(double F, double H, double P, double K) (défini dans CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique) | CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique | [static]
masse_vol(double P, double K) (défini dans CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique) | CalculsGenerauxThermodynamique::CCalculsGenerauxThermodynamique | [static]
Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste alphabétique

Index des classes

B | C | G | I | P | R | S | T | V
B
CMBIN (formatMBIN)
P
rsurf_io (formatRSBIN) t_curve (formatRSBIN)
bintetraface (formatMBIN)
G
ParticuleIO (particleio) rsurf_iso_contouring (formatRSBIN) t_pos (formatCoreBIN)
bintetrahedre (formatMBIN) Gabe_rw (gabe_io) progressionInfo
S
trimeshmodel (formatMBIN)
C
I
progressOperation SurfaceMerging (surf_merge)
V
CCalculsGenerauxThermodynamique (CalculsGenerauxThermodynamique) ioFace (formatCoreBIN)
R
T
VolumesSplitter (volumes_splitter)
CformatBIN (formatCoreBIN) ioModel (formatCoreBIN) rsurf_data (formatRSBIN) t_binNode (formatMBIN)
B | C | G | I | P | R | S | T | V
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatCoreBIN::CformatBIN Liste des membres

Liste complète des membres de formatCoreBIN::CformatBIN, y compris les membres hérités :
CformatBIN() | formatCoreBIN::CformatBIN
ExportBIN(const char *strFileName, ioModel &modelExport) | formatCoreBIN::CformatBIN
GetSurfAire(const ioModel &model, const int &indiceface) | formatCoreBIN::CformatBIN
ImportBIN(ioModel &modelImport, const char *strFileName) | formatCoreBIN::CformatBIN
~CformatBIN() | formatCoreBIN::CformatBIN
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatCoreBIN::t_pos Liste des membres

Liste complète des membres de formatCoreBIN::t_pos, y compris les membres hérités :
operator float *() (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos | [inline]
operator==(const t_pos &_v) (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos | [inline]
operator[](int _i) const (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos | [inline]
t_pos(float _x, float _y, float _z) (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos | [inline]
v (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos |
x (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos |
y (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos |
z (défini dans formatCoreBIN::t_pos) | formatCoreBIN::t_pos |
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatMBIN::CMBIN Liste des membres

Liste complète des membres de formatMBIN::CMBIN, y compris les membres hérités :
CMBIN() | formatMBIN::CMBIN | [inline]
ComputeVolume(trimeshmodel &trimesh) (défini dans formatMBIN::CMBIN) | formatMBIN::CMBIN | [static]
LoadMesh(const char *strFileName) | formatMBIN::CMBIN |
SaveMesh(const char *strFileName, trimeshmodel &trimesh) | formatMBIN::CMBIN |
~CMBIN() | formatMBIN::CMBIN | [inline]
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatRSBIN::rsurf_data Liste des membres

Liste complète des membres de formatRSBIN::rsurf_data, y compris les membres hérités :
GetFaceEnergy(const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &recordIndex, std::size_t &idstep, float &energy) const | formatRSBIN::rsurf_data |
GetFaceInfo(const std::size_t &rsIndex, const std::size_t &faceIndex, std::size_t &vertexA, std::size_t &vertexB, std::size_t &vertexC, std::size_t &recordCount) const | formatRSBIN::rsurf_data |
GetFaceSumEnergy(const std::size_t &rsIndex, const std::size_t &faceIndex) | formatRSBIN::rsurf_data |
GetFileInfos(std::size_t &rs_size, std::size_t &nodes_size, std::size_t &nbtimestep, float &timestep, std::string &recordType) const | formatRSBIN::rsurf_data |
GetNodePositionValue(const std::size_t &nodeIndex, float &x, float &y, float &z) const | formatRSBIN::rsurf_data |
GetRsCount() | formatRSBIN::rsurf_data |
GetRsInfo(const std::size_t &rsIndex, std::size_t &nbfaces, std::string &rs_name, int &xmlid) const | formatRSBIN::rsurf_data |
GetStruct() (défini dans formatRSBIN::rsurf_data) | formatRSBIN::rsurf_data | [protected]
Make(const std::size_t &tabNodesSize, const std::size_t &tabRsSize, const int &nbtimestep, const float &timestep, const std::string &record_type="SPL_STANDART") | formatRSBIN::rsurf_data |
MakeRs(const std::size_t &rsIndex, const std::size_t &nbfacesconst, const std::string &rs_name, const int &xmlid) | formatRSBIN::rsurf_data |
rsurf_data() (défini dans formatRSBIN::rsurf_data) | formatRSBIN::rsurf_data |
SetFaceEnergy(const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &recordIndex, const std::size_t &idstep, const float &energy) | formatRSBIN::rsurf_data |
SetFaceInfo(const std::size_t &rsIndex, const std::size_t &faceIndex, const std::size_t &vertexA, const std::size_t &vertexB, const std::size_t &vertexC, const std::size_t &recordCount) | formatRSBIN::rsurf_data |
SetNodeValue(const std::size_t &nodeIndex, const float &x, const float &y, const float &z) | formatRSBIN::rsurf_data |
SetRsBinData(t_ExchangeData *rsData) | formatRSBIN::rsurf_data |
SetRsBinData(t_ExchangeData &rsData) (défini dans formatRSBIN::rsurf_data) | formatRSBIN::rsurf_data |
SetStruct(t_ExchangeData *extData) (défini dans formatRSBIN::rsurf_data) | formatRSBIN::rsurf_data | [protected]
~rsurf_data() (défini dans formatRSBIN::rsurf_data) | formatRSBIN::rsurf_data |
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatRSBIN::rsurf_io Liste des membres

Liste complète des membres de formatRSBIN::rsurf_io, y compris les membres hérités :
Load(const std::string &fileName, rsurf_data &data) (défini dans formatRSBIN::rsurf_io) | formatRSBIN::rsurf_io | [static]
rsurf_io() (défini dans formatRSBIN::rsurf_io) | formatRSBIN::rsurf_io |
Save(const std::string &fileName, rsurf_data &data) (défini dans formatRSBIN::rsurf_io) | formatRSBIN::rsurf_io | [static]
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatRSBIN::rsurf_iso_contouring Liste des membres

Liste complète des membres de formatRSBIN::rsurf_iso_contouring, y compris les membres hérités :
GetIsoLevelCurves(const float &isolvl, std::list< t_curve > &curvlst) | formatRSBIN::rsurf_iso_contouring
GetMinMax(float &min, float &max) | formatRSBIN::rsurf_iso_contouring
rsurf_iso_contouring(const rsurf_data &data, const std::size_t &rsIndex) | formatRSBIN::rsurf_iso_contouring
SmoothGrid(const int &smoothcount) | formatRSBIN::rsurf_iso_contouring
~rsurf_iso_contouring() (défini dans formatRSBIN::rsurf_iso_contouring) | formatRSBIN::rsurf_iso_contouring
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

gabe_io::Gabe_rw Liste des membres

Liste complète des membres de gabe_io::Gabe_rw, y compris les membres hérités :
AppendFloatCol(const floatarray &coldata, const string &coltitle, const int &precision=12) | gabe_io::Gabe_rw
AppendIntCol(const intarray &coldata, const string &coltitle) | gabe_io::Gabe_rw
AppendStrCol(const stringarray &coldata, const string &coltitle) | gabe_io::Gabe_rw
Gabe_rw(const size_t &sizeHint) | gabe_io::Gabe_rw
Gabe_rw() (défini dans gabe_io::Gabe_rw) | gabe_io::Gabe_rw
GetColTitle(const size_t &idcol) | gabe_io::Gabe_rw
GetTabTypes() | gabe_io::Gabe_rw
IsReadOnly() | gabe_io::Gabe_rw
Load(const string &fileName) | gabe_io::Gabe_rw
operator[](size_t indicecol) | gabe_io::Gabe_rw
ReadColFloat(const size_t &idcol, floatarray &coldata) (défini dans gabe_io::Gabe_rw) | gabe_io::Gabe_rw
ReadColInt(const size_t &idcol, intarray &coldata) (défini dans gabe_io::Gabe_rw) | gabe_io::Gabe_rw
ReadColStr(const size_t &idcol, stringarray &coldata) (défini dans gabe_io::Gabe_rw) | gabe_io::Gabe_rw
Save(const string &fileName) | gabe_io::Gabe_rw
SetReadOnly(const bool &ReadOnly=true) | gabe_io::Gabe_rw
size() const | gabe_io::Gabe_rw
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

particleio::ParticuleIO Liste des membres

Liste complète des membres de particleio::ParticuleIO, y compris les membres hérités :
Close() | particleio::ParticuleIO
GetHeaderData(float &timeStep, unsigned long &nbParticles, unsigned long &nbStepMax) | particleio::ParticuleIO
NewParticle(const unsigned long &firsttimestep) | particleio::ParticuleIO
NewPositionParticle(const float &x, const float &y, const float &z, const float &energy) | particleio::ParticuleIO
NextParticle(unsigned long &firstTimeStep, unsigned long &nbTimeStep) | particleio::ParticuleIO
NextTimeStep(float &x, float &y, float &z, float &energy) | particleio::ParticuleIO
OpenForRead(const std::string &fileName) | particleio::ParticuleIO
OpenForWrite(const std::string &fileName) (défini dans particleio::ParticuleIO) | particleio::ParticuleIO
ParticuleIO() (défini dans particleio::ParticuleIO) | particleio::ParticuleIO
SetHeaderData(const float &timeStep) | particleio::ParticuleIO
~ParticuleIO() (défini dans particleio::ParticuleIO) | particleio::ParticuleIO
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

progressOperation Liste des membres

Liste complète des membres de progressOperation, y compris les membres hérités :
GetState(float *thisLvlProg) (défini dans progressOperation) | progressOperation | [inline]
progressOperation(progressOperation *parentOperation, unsigned int sonEstimation=1) | progressOperation | [inline]
PushProgression(float incProg) | progressOperation | [inline, protected]
~progressOperation() (défini dans progressOperation) | progressOperation | [inline]
Généré le Fri Jan 29 11:31:40 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

progressionInfo Liste des membres

Liste complète des membres de progressionInfo, y compris les membres hérités :
DoShowProgression(float newProg) (défini dans progressionInfo) | progressionInfo | [inline, protected, virtual]
GetCurrentProgression() (défini dans progressionInfo) | progressionInfo | [inline]
GetMainOperation() | progressionInfo | [inline]
OutputCurrentProgression() | progressionInfo | [inline]
progressionInfo(int firstLevelEstimation) | progressionInfo | [inline]
~progressionInfo() (défini dans progressionInfo) | progressionInfo | [inline, virtual]
Généré le Fri Jan 29 11:31:39 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

surf_merge::SurfaceMerging Liste des membres

Liste complète des membres de surf_merge::SurfaceMerging, y compris les membres hérités :
GetGroupInformation(const int &idel, std::vector< std::size_t > &faceIds) | surf_merge::SurfaceMerging |
GetGroups() | surf_merge::SurfaceMerging |
LoadGroups(const formatCoreBIN::ioModel &model) | surf_merge::SurfaceMerging |
SavePolyToPolyFile(const char *strFileName) | surf_merge::SurfaceMerging |
SurfaceMerging() (défini dans surf_merge::SurfaceMerging) | surf_merge::SurfaceMerging |
~SurfaceMerging() (défini dans surf_merge::SurfaceMerging) | surf_merge::SurfaceMerging | [virtual]
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

volumes_splitter::VolumesSplitter Liste des membres

Liste complète des membres de volumes_splitter::VolumesSplitter, y compris les membres hérités :
GetInternalFaces(std::vector< std::size_t > &internalFaceIds, const int &volumeXmlIdFilter=-1) | volumes_splitter::VolumesSplitter |
GetTetraByPosition(const formatMBIN::trimeshmodel &tetramodel, const float &x, const float &y, const float &z, const bool &reloadTetraModel=false) | volumes_splitter::VolumesSplitter |
GetVolumeInformation(const int &idel, int &volumeXmlId, double &volume, std::vector< std::size_t > &faceIds, std::vector< std::size_t > &volNeigh) | volumes_splitter::VolumesSplitter |
GetVolumes() | volumes_splitter::VolumesSplitter | [inline]
GetVolumeXmlId(const int &idel) | volumes_splitter::VolumesSplitter |
LoadDomain(const formatCoreBIN::ioModel &model, const formatMBIN::trimeshmodel &tetramodel) | volumes_splitter::VolumesSplitter |
VolumesSplitter() (défini dans volumes_splitter::VolumesSplitter) | volumes_splitter::VolumesSplitter |
~VolumesSplitter() (défini dans volumes_splitter::VolumesSplitter) | volumes_splitter::VolumesSplitter |
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Membres de classe - Fonctions

  • Tout
  • Fonctions
  • Variables
  • a
  • c
  • e
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • ~

- a -

  • AppendFloatCol() : gabe_io::Gabe_rw
  • AppendIntCol() : gabe_io::Gabe_rw
  • AppendStrCol() : gabe_io::Gabe_rw

- c -

  • CformatBIN() : formatCoreBIN::CformatBIN
  • Close() : particleio::ParticuleIO
  • CMBIN() : formatMBIN::CMBIN

- e -

  • ExportBIN() : formatCoreBIN::CformatBIN

- g -

  • Gabe_rw() : gabe_io::Gabe_rw
  • GetColTitle() : gabe_io::Gabe_rw
  • GetFaceEnergy() : formatRSBIN::rsurf_data
  • GetFaceInfo() : formatRSBIN::rsurf_data
  • GetFaceSumEnergy() : formatRSBIN::rsurf_data
  • GetFileInfos() : formatRSBIN::rsurf_data
  • GetGroupInformation() : surf_merge::SurfaceMerging
  • GetGroups() : surf_merge::SurfaceMerging
  • GetHeaderData() : particleio::ParticuleIO
  • GetInternalFaces() : volumes_splitter::VolumesSplitter
  • GetIsoLevelCurves() : formatRSBIN::rsurf_iso_contouring
  • GetMainOperation() : progressionInfo
  • GetMinMax() : formatRSBIN::rsurf_iso_contouring
  • GetNodePositionValue() : formatRSBIN::rsurf_data
  • GetRsCount() : formatRSBIN::rsurf_data
  • GetRsInfo() : formatRSBIN::rsurf_data
  • GetSurfAire() : formatCoreBIN::CformatBIN
  • GetTabTypes() : gabe_io::Gabe_rw
  • GetTetraByPosition() : volumes_splitter::VolumesSplitter
  • GetVolumeInformation() : volumes_splitter::VolumesSplitter
  • GetVolumes() : volumes_splitter::VolumesSplitter
  • GetVolumeXmlId() : volumes_splitter::VolumesSplitter

- i -

  • ImportBIN() : formatCoreBIN::CformatBIN
  • IsReadOnly() : gabe_io::Gabe_rw

- l -

  • Load() : gabe_io::Gabe_rw
  • LoadDomain() : volumes_splitter::VolumesSplitter
  • LoadGroups() : surf_merge::SurfaceMerging
  • LoadMesh() : formatMBIN::CMBIN

- m -

  • Make() : formatRSBIN::rsurf_data
  • MakeRs() : formatRSBIN::rsurf_data

- n -

  • NewParticle() : particleio::ParticuleIO
  • NewPositionParticle() : particleio::ParticuleIO
  • NextParticle() : particleio::ParticuleIO
  • NextTimeStep() : particleio::ParticuleIO

- o -

  • OpenForRead() : particleio::ParticuleIO
  • operator[]() : gabe_io::Gabe_rw
  • OutputCurrentProgression() : progressionInfo

- p -

  • progressionInfo() : progressionInfo
  • progressOperation() : progressOperation
  • PushProgression() : progressOperation

- r -

  • rsurf_iso_contouring() : formatRSBIN::rsurf_iso_contouring

- s -

  • Save() : gabe_io::Gabe_rw
  • SaveMesh() : formatMBIN::CMBIN
  • SavePolyToPolyFile() : surf_merge::SurfaceMerging
  • SetFaceEnergy() : formatRSBIN::rsurf_data
  • SetFaceInfo() : formatRSBIN::rsurf_data
  • SetHeaderData() : particleio::ParticuleIO
  • SetNodeValue() : formatRSBIN::rsurf_data
  • SetReadOnly() : gabe_io::Gabe_rw
  • SetRsBinData() : formatRSBIN::rsurf_data
  • size() : gabe_io::Gabe_rw
  • SmoothGrid() : formatRSBIN::rsurf_iso_contouring

- ~ -

  • ~CformatBIN() : formatCoreBIN::CformatBIN
  • ~CMBIN() : formatMBIN::CMBIN
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Membres de classe - Variables

  • Tout
  • Fonctions
  • Variables
  • a : formatCoreBIN::ioFace
  • b : formatCoreBIN::ioFace
  • c : formatCoreBIN::ioFace
  • faces : formatCoreBIN::ioModel
  • idEn : formatCoreBIN::ioFace
  • idMat : formatCoreBIN::ioFace
  • idRs : formatCoreBIN::ioFace
  • marker : formatMBIN::bintetraface
  • neighboor : formatMBIN::bintetraface
  • vertices : formatCoreBIN::ioModel
Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Légende du graphe

  • Classes

Légende du graphe

Cette page explique comment interpréter les graphes générés par doxygen.

Considérez l'exemple suivant :

/*! Classe invisible à cause d'une troncature */
class Invisible { };

/*! Classe tronquée, la relation d'héritage est masquée */
class Truncated : public Invisible { };

/*! Classe non documentée avec des commentaires Doxygen */
class Undocumented { };

/*! Classe dérivée par héritage public */
class PublicBase : public Truncated { };

/*! Un modèle de classe */
template<class T> class Templ { };

/*! Classe dérivée par héritage protégé */
class ProtectedBase { };

/*! Classe dérivée par héritage privé */
class PrivateBase { };

/*! Classe utilisée par la classe dérivée */
class Used { };

/*! Super-classe qui hérite de plusieurs autres classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

Si la valeur 240 est attribuée au tag MAX_DOT_GRAPH_HEIGHT du fichier de configuration, cela génèrera le graphe suivant :

Les rectangles du graphe ci-dessus ont la signification suivante :

  • Un rectangle plein noir représente la structure ou la classe pour laquelle le graphe est généré.
  • Un rectangle avec un bord noir indique une classe ou une structure documentée.
  • Un rectangle avec un bord gris indique une classe ou une structure non documentée.
  • Un rectangle avec un bord rouge indique une structure ou une classe documentée pour laquelle des relations d'héritage ou de collaboration manquent. Un graphe est tronqué s'il n'entre pas dans les limites spécifiées.

Les flèches ont la signification suivante :

  • Une flèche bleu foncé est utilisée pour visualiser une relation d'héritage public entre deux classes.
  • Une flèche vert foncé est utilisée pour une relation d'héritage protégé.
  • Une flèche rouge foncé est utilisée pour une relation d'héritage privé.
  • Une flèche violette en pointillés est utilisée si une classe est contenue ou utilisée par une autre classe. La flèche est étiquetée avec la ou les variable(s) qui permettent d'accéder à la classe ou structure pointée.
  • Une flèche verte en pointillés indique une relation entre une classe instanciée et le modèle de classe utilisé. La flèche est étiquetée avec les paramètres de modèle de la classe instanciée.
Généré le Fri Jan 29 11:31:43 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Page principale

  • Classes

libsimpa Documentation

1.1.4

Généré le Fri Jan 29 11:31:36 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatCoreBIN::ioFace Liste des membres

Liste complète des membres de formatCoreBIN::ioFace, y compris les membres hérités :
a | formatCoreBIN::ioFace |
b | formatCoreBIN::ioFace |
c | formatCoreBIN::ioFace |
idEn | formatCoreBIN::ioFace |
idMat | formatCoreBIN::ioFace |
idRs | formatCoreBIN::ioFace |
operator==(const ioFace &_f) (défini dans formatCoreBIN::ioFace) | formatCoreBIN::ioFace | [inline]
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatCoreBIN::ioModel Liste des membres

Liste complète des membres de formatCoreBIN::ioModel, y compris les membres hérités :
faces | formatCoreBIN::ioModel
vertices | formatCoreBIN::ioModel
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatMBIN::bintetraface Liste des membres

Liste complète des membres de formatMBIN::bintetraface, y compris les membres hérités :
marker | formatMBIN::bintetraface
neighboor | formatMBIN::bintetraface
sommets (défini dans formatMBIN::bintetraface) | formatMBIN::bintetraface
Généré le Fri Jan 29 11:31:41 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatMBIN::bintetrahedre Liste des membres

Liste complète des membres de formatMBIN::bintetrahedre, y compris les membres hérités :
idVolume (défini dans formatMBIN::bintetrahedre) | formatMBIN::bintetrahedre |
operator==(const bintetrahedre &_f) (défini dans formatMBIN::bintetrahedre) | formatMBIN::bintetrahedre | [inline]
sommets (défini dans formatMBIN::bintetrahedre) | formatMBIN::bintetrahedre |
tetrafaces (défini dans formatMBIN::bintetrahedre) | formatMBIN::bintetrahedre |
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatMBIN::t_binNode Liste des membres

Liste complète des membres de formatMBIN::t_binNode, y compris les membres hérités :
node (défini dans formatMBIN::t_binNode) | formatMBIN::t_binNode |
operator==(const t_binNode &_f) (défini dans formatMBIN::t_binNode) | formatMBIN::t_binNode | [inline]
t_binNode() (défini dans formatMBIN::t_binNode) | formatMBIN::t_binNode | [inline]
t_binNode(const Floatb &x, const Floatb &y, const Floatb &z) (défini dans formatMBIN::t_binNode) | formatMBIN::t_binNode | [inline]
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatMBIN::trimeshmodel Liste des membres

Liste complète des membres de formatMBIN::trimeshmodel, y compris les membres hérités :
nodes (défini dans formatMBIN::trimeshmodel) | formatMBIN::trimeshmodel
tetrahedres (défini dans formatMBIN::trimeshmodel) | formatMBIN::trimeshmodel
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1


libsimpa: Liste des membres

formatRSBIN::t_curve Liste des membres

Liste complète des membres de formatRSBIN::t_curve, y compris les membres hérités :
A (défini dans formatRSBIN::t_curve) | formatRSBIN::t_curve
B (défini dans formatRSBIN::t_curve) | formatRSBIN::t_curve
Généré le Fri Jan 29 11:31:42 2010 pour libsimpa par doxygen 1.6.1