I-SIMPA Scripting Guide: Guide de création de script I-SIMPA

  • Page principale
  • Espaces de nommage
  • Classes

Guide de création de script I-SIMPA

1.1.4

Il y a deux finalitées à la création de script dans I-SIMPA La première vise à ajouter des fonctionnalitées au logiciel via des menus supplémentaire lors-ce que l'on fait un clique droit sur un élément. On peut également ajouter des données aux arbres du projet.

  • Ajouter des fonctionnalitées
  • Ajouter des données dans les projets
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Ajouter des fonctionnalitées

Guide de création de script I-SIMPA

Ajouter des fonctionnalitées

L'ajout d'une nouvelle fonction se fait en 4 étapes :

  • Créer un dossier(module) dans le dossier UserScript// et ajouter un fichier dans ce dossier nommé "__ui_startup.py" qui va importer le module.
  • Enregistrer les événements lors de l'initialisation du gestionnaire de menu.
  • Enregistrer un nouveau gestionnaire de menu dans le fichier __init__.py
  • Créer la méthode "getmenu" qui va ajouter les nouvelles fonctions dans la structure de données en paramètre.

Enregistrer les événements

Chaque fonction implémenté en python doit être associé à un indice. Cet indice est obtenu grâce à l'enregistrement de cette fonction. Cette indice sera utilisé ultérieurement dans la structure du menu à la dernière étape

Vous devez appeler la méthode uictrl::application::register_event et stocker l'indice retourné.

Exemple
class manager:
    """
        This class make the user able to enable or disable a group of emitters with one click only
    """
    def __init__(self):
        """
            Constructor. Register the two new menu functions
        """
        self.enable_grp_sourcesid=uictrl.application.register_event(self.enable_grp_sources)
        self.disable_grp_sourcesid=uictrl.application.register_event(self.disable_grp_sources)
    def set_grp_src_activation(self,idgrp,newstate):
        grpsrc=uictrl.element(idgrp)
        all_property=grpsrc.getallelementbytype(uictrl.element_type.ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PROPRIETES)
        for prop in all_property:
            uictrl.element(prop).updateboolconfig("enable",newstate)
    def enable_grp_sources(self,idgrp):
        """
            Called by user interface when the user click on the enable menu item
        """
        self.set_grp_src_activation(idgrp,True)
    def disable_grp_sources(self,idgrp):
        """
            Called by user interface when the user click on the disable menu item
        """
        self.set_grp_src_activation(idgrp,False)

Enregistrer un nouveau gestionnaire de menu

La méthode uictrl::application::register_menu_manager permet de déclarer un nouveau gestionnaire de menu.

Exemple
uictrl.application.register_menu_manager(uictrl.element_type.ELEMENT_TYPE_SCENE_SOURCES, manager())
  • Le premier paramètre uictrl::element_type indique le type d'élément associé avec le gestionnaire.
  • Le deuxième paramètre correspond à l'instance du gestionnaire

Créer la méthode "getmenu"

Quand l'utilisateur fait un clique droit sur un élément de l'arbre du projet I-SIMPA appel la méthode getmenu pour chaque gestionnaire lié à ce type d'élément.

Votre méthode doit retourner vrai afin de prendre en compte les modifications.

Exemple
    def getmenu(self,typeel,idel,menu):
        """
            Called by the user interface
            The list menu structure contains the current implemented functions.
        """
        submenu=[(uictrl._("Enable"),self.enable_grp_sourcesid),(uictrl._("Disable"),self.disable_grp_sourcesid)]
        menu.insert(2,(uictrl._("All emitters"),submenu))
        menu.insert(2,())
        return True

Executer du code lors de la mise à jour d'un élément

Vous pouvez lier une méthode python à n'importe quel élément de l'application, quand cet élément sera modifié par le programme ou par l'utilisateur alors cette méthode sera appelé avec en paramètre l'indice de l'élément mis à jour (indice même de l'élément ou d'un de ses fils) La méthode uictrl::element::register_update_manager vous permet d'effectuer cette opération.

Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Ajouter des données dans les projets

Guide de création de script I-SIMPA

Ajouter des données dans les projets

Ajouter des propriétés aux éléments n'est pas suffisant.

Vous devez prendre le contrôle de ses élément afin d'implémenter des contraintes de propriétés et pour ajouter plus de fonctionnalitées.

Les étapes pour ajouter un nouvel élément sont :

  • Créer un dossier dans UserScript/
  • Créer un nouveau type d'élément dans le dossier UserScript/votre_module/__init__.py
  • Enregistrer le nouveau module dans le script __project_loading__.py

Créer un nouveau type d'élément

L'exemple de notre guide est la création d'un lien entre les projets et un nouveau code de calcul. En premier lieu, il faut créer une classe héritant de uictrl::element et ayant comme type d'élément de base uictrl::element_type::ELEMENT_TYPE_CORE_CORE.

Exemple
class mdf(uictrl.element):
    """
      Diffusion model calculation core.
    """
    def __init__(self,idel):
        uictrl.element.__init__(self,idel)

        if not self.hasproperty("exeName"): #Test if this is a new project initialisation
            #If this is a new project then we add properties
            #Add tetgen parameters
            self.appendfilsbytype(uictrl.element_type.ELEMENT_TYPE_CORE_CORE_CONFMAILLAGE)
            #Add frequencies selection
            self.appendfilsbytype(uictrl.element_type.ELEMENT_TYPE_CORE_CORE_BFREQSELECTION)
            #Add configuration core
            coreconf=uictrl.element(self.appendfilsbytype(uictrl.element_type.ELEMENT_TYPE_CORE_CORE_CONFIG))
            #Append hidden config, used by I-SIMPA to find the core files and binaries
            uictrl.element(self.appendpropertytext("modelName","","mesh.cbin",True,True)).hide()
            uictrl.element(self.appendpropertytext("tetrameshFileName","","tetramesh.mbin",True,True)).hide()
            uictrl.element(self.appendpropertytext("exeName","","md.py")).hide()
            uictrl.element(self.appendpropertytext("corePath","","md\\")).hide()

            #User options
            coreconf.appendpropertylist("solver_mode","Calculation mode",[["Time","Static"],[0,1]],0,False,1,True)
            coreconf.appendpropertybool("with_direct_sound","Use direct sound",True,True)
            _("Calculation mode")
            _("Use direct sound")
            _("Time")
            _("Static")

        else:
            pass #Here in case of loading an existing project
Dans le constructeur __init__ les propriétés sont ajoutées. Toutefois rien n'est fait si elles existent déjà car ce constructeur est appellé également lors-ce que l'utilisateur charge un projet déjà existant.

Libellé de l'élément dans l'arbre du projet

Par défaut c'est le nom de la classe qui est affiché dans l'arbre du projet. Pour modifier le libellé vous devez surcharger la fonction gettreelabel.

Exemple
    def gettreelabel(self):
        """
            Return label
        """
        return "Mdf"

Icone

Il y a deux types d'icônes :

  • Les indices fixes, visible dans l'énumeration uictrl::graph et déclaré par element::geticonid(self) qui doit retourne un membre de l'énumeration.
  • La déclaration locale des icônes via la fonction element::geticonpath(self) qui doit retourner le chemin d'accès au fichier d'icône (*.ico)
Exemple
    def geticonid(self,state_open):
        """
            Return tree icon Id
        """
        if state_open:
            return uictrl.graph.GRAPH_FOLDER_OPEN

Evenement de mise à jour

Dès que l'utilisateur modifie une propriété l'application appelle la méthode uictrl::element::modified à partir de la propriété jusqu'à l'élément racine du projet.

Cette méthode trés utile vous permettra par exemple d'implémenter les contraintes dans les propriétés.

Dans l'exemple, elle est utilisée afin de désactiver l'accès à la modification des propriétés dépendantes du temps si l'utilisateur séléctionne une méthode de résolution statique.

Exemple
    def modified(self,idelmodified):
        #In case of sub element modification this func is call by ui
        #We disable the time dependant parameters in case of static solver mode
        if uictrl.element(idelmodified).getinfos()["name"]=="solver_mode":
            elconf=uictrl.element(self.getelementbytype(uictrl.element_type.ELEMENT_TYPE_CORE_CORE_CONFIG))
            is_temporal=(elconf.getlistconfig("solver_mode")==0)
            elconf.setreadonlyconfig("duree_simulation",not is_temporal)
            elconf.setreadonlyconfig("pasdetemps",not is_temporal)
        uictrl.element.modified(self,idelmodified)

Enregistrer le nouveau module

Lors-ce que l'utilisateur créé ou charge un projet tout les fichiers nommés "__project_loading__.py" et présent dans le dossier UserScript/ et ses sous dossiers sont éxécutés.

Il est nécessaire de créer ce fichier dans votre module afin d'ajouter celui-ci dans les projets.

Il faut au préalable vérifier que l'ajout n'a pas été déjà effectué. Dès lors il faut utiliser la méthode uictrl::element::appenduserelement.

Note:
Vous pouvez utiliser la librairie uictrl déjà importé sous le nom ui.
Exemple
rootcore=ui.element(ui.application.getrootcore())
#Check if our mod has been already inserted
if rootcore.getelementbylibelle("mdf")==-1: #Then append our mod
    rootcore.appenduserelement(ui.element_type.ELEMENT_TYPE_CORE_CORE,"mdf","mdf")
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste des classes

  • Liste des classes
  • Hiérarchie des classes
  • Membres de classe

Liste des classes

Liste des classes, structures, unions et interfaces avec une brève description :
uictrl::application | Classe python de contrôle de I-SIMPA
uictrl::e_file |
uictrl::Element | Alias
uictrl::element | Contrôle d'un élément implémenté en python ou c++
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Référence de la classe uictrl::application

uictrl::application

Référence de la classe uictrl::application

Classe python de contrôle de I-SIMPA. Plus de détails...

Liste de tous les membres

Fonctions membres publiques statiques

static void | clearlogdata ()
static void | clearshellhisto ()
static std::string | getcachedir ()
static boost::python::list | getdataarray (const element &pyel)
static std::string | getlastcalculationpath ()
static std::string | getlocale ()
static int | getrootcore ()
static int | getrootpreference ()
static int | getrootreport ()
static int | getrootscene ()
static boost::python::tuple | getuserinput (const std::string &title, const std::string &msg, boost::python::dict rows)
static bool | importscene (const std::string &path, bool keepexistingfacegroup=true, bool docorrection=true, bool domeshsurface=false, const std::string &paramTetgen="")
static void | loadproject (const std::string &path)
static void | newproject ()
static int | register_event (boost::python::object &func)
static void | register_menu_manager (const int &element_typeid, boost::python::object &manager)
static void | reloadgroupsfrommodel ()
static void | savelog (const std::string &path)
static void | saveproject (const std::string &path="")
static void | saveshell (const std::string &path)
static void | sendevent (const element &pyel, const int &idevent, boost::python::dict parameters=boost::python::dict())

Description détaillée

Classe python de contrôle de I-SIMPA.

Documentation des fonctions membres

static void uictrl::application::clearlogdata ( ) [static]

Efface l'historique de la fenêtre de messages

static void uictrl::application::clearshellhisto ( ) [static]

Efface l'historique de la fenêtre de console python

static std::string uictrl::application::getcachedir ( ) [static]

Retourne le chemin d'accès au dossier temporaire du projet

static boost::python::list uictrl::application::getdataarray ( const element & pyel ) [static]

Retourne les données sous forme de tableau associé à un élément Pour les éléments ayant des propriétés il est rendu un tableau de propriété Pour les éléments e_file portant des données binaires il est rendu le tableau avec le post-traitement de I-SIMPA.

Paramètres:
pyel Les données du tableau seront extraites à partir de cet élément.
static std::string uictrl::application::getlastcalculationpath ( ) [static]

Retourne le chemin du dernier calcul effectué.

static std::string uictrl::application::getlocale ( ) [static]

Retourne la langue séléctionné par l'utilisateur dans la forme standart. La forme standart correspond à celle utilisée dans les système UNIX: Il s'agit d'une chaine de caractères sous forme xx ou xx_YY, où xx correspond à la norme ISO 639 et YY à la norme ISO 3166 relatif au pays. Il y a par exemple "en", "en_GB", "en_US" ou "fr_FR".

static int uictrl::application::getrootcore ( ) [static]

Acceder à l'élément racine d'un arbre

Renvoie:
L'indice de l'élément racine de l'arbre des codes de calcul
static int uictrl::application::getrootpreference ( ) [static]

Acceder à l'élément racine des préférences utilisateur

Renvoie:
L'indice de l'élément racine de l'arbre propre à l'utilisateur (et non au projet)
static int uictrl::application::getrootreport ( ) [static]

Acceder à l'élément racine d'un arbre

Renvoie:
L'indice de l'élément racine de l'arbre des résulats de calculs
static int uictrl::application::getrootscene ( ) [static]

Acceder à l'élément racine d'un arbre

Renvoie:
L'indice de l'élément racine de l'arbre de la scène
static boost::python::tuple uictrl::application::getuserinput | ( | const std::string & | title,
 |  | const std::string & | msg,
 |  | boost::python::dict | rows |
 | ) |  |  | [static]

Demande à l'utilisateur d'entrer des valeurs dans des champs via l'interface

Paramètres:
title | Titre de la fenêtre
msg | Message affiché à l'utilisateur
rows | Champs en entrée {"champ1" : "valeur par défaut","champ2" : "valeur par défaut","liste champ3" : ["choix 1","choix 2","choix 3"],..}
Renvoie:
Tuple (Booléen, Liste) Le booléen indique le choix de l'utilisateur (ok, annuler) et la liste contient les valeurs des champs dans le même ordre que le paramètre rows.
static bool uictrl::application::importscene | ( | const std::string & | path,
 |  | bool | keepexistingfacegroup = true,
 |  | bool | docorrection = true,
 |  | bool | domeshsurface = false,
 |  | const std::string & | paramTetgen = "" |
 | ) |  |  | [static]

Importe un model 3D qui remplacera le modèle du projet courant. Les formats de model supportés sont *.3ds;*.ply;*.bin;*.poly

Paramètres:
path | Chemin du fichier de modèle
keepexistingfacegroup | A vrai, Le groupes seront conservés grâce aux coordonnées similaires entre les anciennes et nouvelles faces.
docorrection | Exécute preprocess.exe pour éclater ou supprimer les faces afin de tente de rendre possible le maillage.
domeshsurface | Tente de mailler la surface du modèle. Cette opération peut augmenter le nombre de faces et elle détruira les informations de couleurs et de textures.
paramTetgen | Paramètres de maillage. Inutile si domeshsurface à faux.
Renvoie:
Vrai en cas de succès. Faux si l'importation a échoué, se référer à la fenêtre de message pour plus d'information.
Paramètres:
path Chemin du fichier à créer
static void uictrl::application::loadproject ( const std::string & path ) [static]

Charge un fichier de projet

Paramètres:
path Chemin du fichier de projet à charger
static void uictrl::application::newproject ( ) [static]

Ferme le projet courant et en créé un nouveau

static int uictrl::application::register_event ( boost::python::object & func ) [static]

Voir Ajouter des fonctionnalitées. Permet de lier un indice de menu à une fonction python.

Paramètres:
func Méthode python à appeler en cas d'execution d'un événement.
Renvoie:
Indice du nouveau type d'événement de I-SIMPA.
static void uictrl::application::register_menu_manager | ( | const int & | element_typeid,
 |  | boost::python::object & | manager |
 | ) |  |  | [static]

Voir Ajouter des fonctionnalitées .Enregistre un nouveau gestionnaire de menu pour ce type d'élément.

Paramètres:
element_typeid | uictrl::element_type Type d'élément lié à ce gestionnaire de menu.
manager | Instance de l'objet du manager.
static void uictrl::application::reloadgroupsfrommodel ( ) [static]

Recharge les faces à partir du modèle

static void uictrl::application::savelog ( const std::string & path ) [static]

Sauvegarde le contenu de la fenêtre de messages.

Paramètres:
path Chemin du fichier à créer
static void uictrl::application::saveproject ( const std::string & path = "" ) [static]

Sauvegarde le projet ouvert

Paramètres:
path Dossier de sauvegarde du projet
static void uictrl::application::saveshell ( const std::string & path ) [static]

Sauvegarde le contenu de la fenêtre de console python.

Paramètres:
path Chemin du fichier à créer
static void uictrl::application::sendevent | ( | const element & | pyel,
 |  | const int & | idevent,
 |  | boost::python::dict | parameters = boost::python::dict() |
 | ) |  |  | [static]

Execution d'un événement.

Paramètres:
pyel | Element de l'arbre concerné
idevent | Evénement interne uictrl::idevent ou événement d'un module python déclaré via application::register_event
parameters | Voir les membres de uictrl::idevent pour plus de détails.
Généré le Tue Jan 19 09:44:50 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Référence de la classe uictrl::e_file

uictrl::e_file

Référence de la classe uictrl::e_file

Graphe d'héritage de uictrl::e_file:
[légende]
Graphe de collaboration de uictrl::e_file:
[légende]

Liste de tous les membres

Fonctions membres publiques

std::string buildfullpath ()
e_file (const element &cpyFrom)
e_file (const wxInt32 &_xmlId)

Description détaillée

Dérive d'un élément, il représente un fichier ou un dossier

Documentation des fonctions membres

std::string uictrl::e_file::buildfullpath ( )

Retourne le chemin relatif de cet élément de fichier.

Généré le Tue Jan 19 09:44:52 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Référence de la structure uictrl::Element

uictrl::Element

Référence de la structure uictrl::Element

Alias. Plus de détails...

Liste de tous les membres

Types publics

typedef element_type | ELEMENT_TYPE
typedef graph | GRAPH
typedef idevent | IDEVENT

Description détaillée

Alias.

Généré le Tue Jan 19 09:44:52 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Référence de la classe uictrl::element

uictrl::element

Référence de la classe uictrl::element

Contrôle d'un élément implémenté en python ou c++. Plus de détails...

Graphe d'héritage de uictrl::element:
[légende]

Liste de tous les membres

Fonctions membres publiques

int | appendfilsbytype (Element::ELEMENT_TYPE etypefils, const std::string &libelle="")
int | appendpropertybool (const std::string &propertyName, const std::string &propertyLabel, bool propertyDefaultValue, bool exportToCore=false)
int | appendpropertycolor (const std::string &propertyName, const std::string &propertyLabel, long defaultRed=0, long defaultGreen=0, long defaultBlue=0)
int | appendpropertydecimal (const std::string &propertyName, const std::string &propertyLabel, float propertyDefaultValue=0.f, bool readOnly=false, int precision=4, bool isMaxValue=false, bool isMinValue=false, float maxValue=0, float minValue=0, bool exportToCore=false)
int | appendpropertyentier (const std::string &propertyName, const std::string &propertyLabel, int propertyDefaultValue=0, bool exportToCore=false, bool isMaxValue=false, bool isMinValue=false, int maxValue=0, int minValue=0)
int | appendpropertyfont (const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue="")
int | appendpropertylist (const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &values, long defaultValue, bool asTitle=false, int hSize=1, bool exportToCore=false)
int | appendpropertyposition (const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &propertyDefaultValue, bool exportToCore=false)
int | appendpropertytext (const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue, bool readOnly=false, bool exportToCore=false)
boost::python::object | appenduserelement (const Element::ELEMENT_TYPE &baseType, const std::string &moduleName, const std::string &className)
boost::python::list | childs ()
void | deleteallelementbytype (Element::ELEMENT_TYPE typeElement)
void | deleteallelementbytyper (Element::ELEMENT_TYPE typeElementToDelete)
bool | deleteelementbyxmlid (int xmlIdElement, bool setModification=true)
element (const element &cpyFrom)
element (const wxInt32 &_xmlId)
boost::python::list | getallelementbytype (Element::ELEMENT_TYPE typeElement)
bool | getboolconfig (const std::string &name)
boost::python::list | getcolorconfig (const std::string &name)
float | getdecimalconfig (const std::string &name)
int | getelementbylibelle (std::string libelle)
int | getelementbytype (Element::ELEMENT_TYPE typeElement)
int | getentierconfig (const std::string &name)
wxInt32 | getid ()
wxInt32 | getindice () const
boost::python::dict | getinfos ()
int | getlistconfig (const std::string &name)
boost::python::list | getmenu ()
boost::python::list | getpositionconfig (const std::string &name)
std::string | getstringconfig (const std::string &name)
bool | hasproperty (const std::string &name)
void | hide (bool visible=false)
void | modified (int elementUpdated)
void | register_update_manager (boost::python::object &pymethod)
void | setreadonlyallconfig (bool readOnly=true, int col=0)
void | setreadonlyconfig (const std::string &name, bool readOnly=true, int col=0)
bool | updateboolconfig (const std::string &name, bool newValue)
bool | updatedecimalconfig (const std::string &name, float newValue)
bool | updateentierconfig (const std::string &name, int newValue)
bool | updatelistconfig (const std::string &name, int newIndex)
bool | updatepositionconfig (const std::string &name, const boost::python::list &newValue)
bool | updatestringconfig (const std::string &name, const std::string &newValue)

Attributs protégés

wxInt32 | xmlId

Description détaillée

Contrôle d'un élément implémenté en python ou c++.

Toute les données du projet dérivent de cette classe. De la simple propriété chaine de caractère, booléen et nombre à décimal jusqu'a un noeud de l'arbre du projet.

Documentation des fonctions membres

int uictrl::element::appendfilsbytype | ( | Element::ELEMENT_TYPE | etypefils,
 |  | const std::string & | libelle = ""
 | ) |  |

Ajoute un nouvel enfant de type etypefils et retourne son indice xml. Retourne -1 en cas d'échec.

Paramètres:
etypefils | Type de l'élément à ajouter
libelle | Libellé de l'élément (n'est pas disponible pour tout les types d'éléments)
int uictrl::element::appendpropertybool | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | bool | propertyDefaultValue,
 |  | bool | exportToCore = false
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
propertyDefaultValue | Valeur par défaut de la propriété
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertycolor | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | long | defaultRed = 0,
 |  | long | defaultGreen = 0,
 |  | long | defaultBlue = 0
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
defaultRed | Niveau de rouge par défaut. [0-255]
defaultGreen | Niveau de vert par défaut. [0-255]
defaultBlue | Niveau de bleu par défaut. [0-255]
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertydecimal | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | float | propertyDefaultValue = 0.f,
 |  | bool | readOnly = false,
 |  | int | precision = 4,
 |  | bool | isMaxValue = false,
 |  | bool | isMinValue = false,
 |  | float | maxValue = 0,
 |  | float | minValue = 0,
 |  | bool | exportToCore = false
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
propertyDefaultValue | Valeur par défaut de la propriété
readOnly | A vrai l'utilisateur ne pourra pas modifier la valeur du champ. Sauf via la fenêtre python.
precision | Nombre de chiffre affiché après la virgule.
isMaxValue | Vrai pour activer les contraintes de limite maximale.
isMinValue | Vrai pour activer les contraintes de limite minimale.
maxValue | Valeur maximum autorisée.
minValue | Valeur minimale autorisée.
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertyentier | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | int | propertyDefaultValue = 0,
 |  | bool | exportToCore = false,
 |  | bool | isMaxValue = false,
 |  | bool | isMinValue = false,
 |  | int | maxValue = 0,
 |  | int | minValue = 0
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
propertyDefaultValue | Valeur par défaut de la propriété
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
isMaxValue | Vrai pour activer les contraintes de limite maximale.
isMinValue | Vrai pour activer les contraintes de limite minimale.
maxValue | Valeur maximum autorisée.
minValue | Valeur minimale autorisée.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertyfont | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | const std::string & | propertyDefaultValue = ""
 | ) |  |

Non implémenté.

int uictrl::element::appendpropertylist | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | const boost::python::list & | values,
 |  | long | defaultValue,
 |  | bool | asTitle = false,
 |  | int | hSize = 1,
 |  | bool | exportToCore = false
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
values | Elements de la liste (non traduit) et leurs indices. [["première option","deuxième option"],[0,1]]
defaultValue | Valeur par défaut de la propriété
asTitle | Vrai si cette propriété doit être la première affichée
hSize | Nombre de colonne occupée par cette propriété.
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertyposition | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | const boost::python::list & | propertyDefaultValue,
 |  | bool | exportToCore = false
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
propertyDefaultValue | Valeur par défaut de la propriété [x,y,z]
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
int uictrl::element::appendpropertytext | ( | const std::string & | propertyName,
 |  | const std::string & | propertyLabel,
 |  | const std::string & | propertyDefaultValue,
 |  | bool | readOnly = false,
 |  | bool | exportToCore = false
 | ) |  |

Ajoute une nouvelle propriété à un élément.

Paramètres:
propertyName | Nom de la propriété. Ce nom doit être unique pour chaque propriété.
propertyLabel | Libellé non traduite de la propriété.
propertyDefaultValue | Valeur par défaut de la propriété
readOnly | A vrai l'utilisateur ne pourra pas modifier la valeur du champ. Sauf via la fenêtre python.
exportToCore | Spécifie l'exportation ou non de cette propriété vers les code de calcul.
Renvoie:
L'indice xml de l'élément ajouté, ou l'indice de l'élément portant déjà ce nom. -1 si la procédure a echoué.
boost::python::object uictrl::element::appenduserelement | ( | const Element::ELEMENT_TYPE & | baseType,
 |  | const std::string & | moduleName,
 |  | const std::string & | className
 | ) |  |

Affecte un module python en tant qu'enfant de se module.

Paramètres:
baseType | Type de base de l'élément
moduleName | Nom du module python (nom du dossier dans UserScript/)
className | Nom de la classe du nouvel élément.
boost::python::list uictrl::element::childs ( )

Retourne l'indice, le type et le nom de chaque enfants

void uictrl::element::deleteallelementbytype ( Element::ELEMENT_TYPE typeElement )

Supprime les enfants immédiat ayant ce type d'élément.

Paramètres:
typeElement Type d'élément
void uictrl::element::deleteallelementbytyper ( Element::ELEMENT_TYPE typeElementToDelete )

Supprime les enfants ayant ce type d'élément de facon récursive.

Paramètres:
typeElement Type d'élément
bool uictrl::element::deleteelementbyxmlid | ( | int | xmlIdElement,
 |  | bool | setModification = true
 | ) |  |

Supprime l'enfant immédiat ayant cet indice.

Paramètres:
xmlIdElement | Indice de l'élément fils
setModification | Cette méthode appelera automatiquement element::modified.
boost::python::list uictrl::element::getallelementbytype ( Element::ELEMENT_TYPE typeElement )

Parcourt récursivement tout les enfants de l'élément et retourne la liste de tout les éléments ayant ce type.

bool uictrl::element::getboolconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété
boost::python::list uictrl::element::getcolorconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété [rouge,vert,bleu] [0-255]
float uictrl::element::getdecimalconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété
int uictrl::element::getelementbylibelle ( std::string libelle )

Retourne le premier enfant ayant le même libellé

int uictrl::element::getelementbytype ( Element::ELEMENT_TYPE typeElement )

Retourne le premier enfant ayant le même type que le paramètre de la méthode.

int uictrl::element::getentierconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété
wxInt32 uictrl::element::getid ( ) [inline]
Renvoie:
Element index
boost::python::dict uictrl::element::getinfos ( )

Retourne un dictionnaire comportant les informations suivantes :

  • typeElement : Type de l'élément (uictrl.element_type)
  • xmlIdElement : Indice de l'élément (
    Voir également:
    GetIndice )
  • expanded : Indique si l'élément est déplié ou non
  • userDestroyable : Indique si l'élément peut être supprimé par l'utilisateur
  • label : Libellé d'origine de l'élément
  • label_located : Libellé traduit dans la langue de l'utilisateur
  • name : Nom de l'élément
  • parentid : Indice de l'élément parent. -1 si aucun
int uictrl::element::getlistconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété
boost::python::list uictrl::element::getmenu ( )

Retourne le menu final (logiciel+python menu manager) sous forme de liste en arbre contenant pour chaque élément de menu le tuple ( libellé traduit, indice event_id )

boost::python::list uictrl::element::getpositionconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété [x,y,z] (m)
std::string uictrl::element::getstringconfig ( const std::string & name )

Retourne la valeur d'une propriété

Paramètres:
name Nom de la propriété. En cas de doute de l'existance de cette propriété merci de vérifier celle-ci via element::hasproperty
Renvoie:
Valeur de la propriété
bool uictrl::element::hasproperty ( const std::string & name )

Retourne Vrai si le nom correspond à une des propriétés de l'élément.

Paramètres:
hasproperty Nom de la propriété
void uictrl::element::hide ( bool visible = false )

Cache cet élément de sorte qu'il ne puisse être visible pour l'utilisateur.

Paramètres:
visible Nouvel état de l'élément
void uictrl::element::modified ( int elementUpdated )

Affecte lui et ses parent comme modifié, et il sera sauvegardé à la prochaine sauvegarde.

Paramètres:
elementUpdated Indice xml de l'élément modifié
void uictrl::element::register_update_manager ( boost::python::object & pymethod )

Lie une fonction python à l'événement de mise à jour d'un élément. Vous pouvez ajouter plusieurs liens, ces liens restent en place jusqu'à la fermeture du projet.

Paramètres:
func Classe python avec une fonction nommé OnUpdate avec un paramètre correspondant à l'indice de l'élément mis à jour (l'élément courant ou un de ses fils)
void uictrl::element::setreadonlyallconfig | ( | bool | readOnly = true,
 |  | int | col = 0
 | ) |  |

Active/Désactive la possibilité de modifier tout les champs pour l'utilisateur pour une colonne donnée

Paramètres:
readOnly | Nouvel état des champs
col | Pour les champ ayant plusieurs colonnes tel que E_Data_Row indique quel colonne sera affectée par la lecture seule.
void uictrl::element::setreadonlyconfig | ( | const std::string & | name,
 |  | bool | readOnly = true,
 |  | int | col = 0
 | ) |  |

Active/Désactive la possibilité de modifier le champ pour l'utilisateur pour un champ donné

Paramètres:
name | Nom du champ
readOnly | Nouvel état du champ
col | Pour les champs ayant plusieurs colonnes tel que E_Data_Row indique quel colonne sera affecté par la lecture seule.
bool uictrl::element::updateboolconfig | ( | const std::string & | name,
 |  | bool | newValue
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newValue | Nouvelle valeur de la propriété
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
bool uictrl::element::updatedecimalconfig | ( | const std::string & | name,
 |  | float | newValue
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newValue | Nouvelle valeur de la propriété
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
bool uictrl::element::updateentierconfig | ( | const std::string & | name,
 |  | int | newValue
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newValue | Nouvelle valeur de la propriété
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
bool uictrl::element::updatelistconfig | ( | const std::string & | name,
 |  | int | newIndex
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newIndex | Nouvelle valeur de la propriété
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
bool uictrl::element::updatepositionconfig | ( | const std::string & | name,
 |  | const boost::python::list & | newValue
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newValue | Nouvelle valeur de la propriété [x,y,z]
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
bool uictrl::element::updatestringconfig | ( | const std::string & | name,
 |  | const std::string & | newValue
 | ) |  |

Met à jour la valeur d'une propriété

Paramètres:
name | Nom de la propriété
newValue | Nouvelle valeur de la propriété
Renvoie:
Vrai si la propriété a été trouvé et mis à jour
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Index hiérarchique

Hiérarchie des classes

Aller au graphe hiérarchique des classes

Cette liste d'héritage est classée approximativement par ordre alphabétique :
  • uictrl::application
  • uictrl::Element
  • uictrl::element
    • uictrl::e_file
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Membres de classe

  • Tout
  • Fonctions
  • a
  • b
  • c
  • d
  • g
  • h
  • i
  • l
  • m
  • n
  • r
  • s
  • u
Liste de tous les membres de classe documentés avec liens vers la documentation de classe de chaque membre :

- a -

  • appendfilsbytype() : uictrl::element
  • appendpropertybool() : uictrl::element
  • appendpropertycolor() : uictrl::element
  • appendpropertydecimal() : uictrl::element
  • appendpropertyentier() : uictrl::element
  • appendpropertyfont() : uictrl::element
  • appendpropertylist() : uictrl::element
  • appendpropertyposition() : uictrl::element
  • appendpropertytext() : uictrl::element
  • appenduserelement() : uictrl::element

- b -

  • buildfullpath() : uictrl::e_file

- c -

  • childs() : uictrl::element
  • clearlogdata() : uictrl::application
  • clearshellhisto() : uictrl::application

- d -

  • deleteallelementbytype() : uictrl::element
  • deleteallelementbytyper() : uictrl::element
  • deleteelementbyxmlid() : uictrl::element

- g -

  • getallelementbytype() : uictrl::element
  • getboolconfig() : uictrl::element
  • getcachedir() : uictrl::application
  • getcolorconfig() : uictrl::element
  • getdataarray() : uictrl::application
  • getdecimalconfig() : uictrl::element
  • getelementbylibelle() : uictrl::element
  • getelementbytype() : uictrl::element
  • getentierconfig() : uictrl::element
  • getid() : uictrl::element
  • getinfos() : uictrl::element
  • getlastcalculationpath() : uictrl::application
  • getlistconfig() : uictrl::element
  • getlocale() : uictrl::application
  • getmenu() : uictrl::element
  • getpositionconfig() : uictrl::element
  • getrootcore() : uictrl::application
  • getrootpreference() : uictrl::application
  • getrootreport() : uictrl::application
  • getrootscene() : uictrl::application
  • getstringconfig() : uictrl::element
  • getuserinput() : uictrl::application

- h -

  • hasproperty() : uictrl::element
  • hide() : uictrl::element

- i -

  • importscene() : uictrl::application

- l -

  • loadproject() : uictrl::application

- m -

  • modified() : uictrl::element

- n -

  • newproject() : uictrl::application

- r -

  • register_event() : uictrl::application
  • register_menu_manager() : uictrl::application
  • register_update_manager() : uictrl::element
  • reloadgroupsfrommodel() : uictrl::application

- s -

  • savelog() : uictrl::application
  • saveproject() : uictrl::application
  • saveshell() : uictrl::application
  • sendevent() : uictrl::application
  • setreadonlyallconfig() : uictrl::element
  • setreadonlyconfig() : uictrl::element

- u -

  • updateboolconfig() : uictrl::element
  • updatedecimalconfig() : uictrl::element
  • updateentierconfig() : uictrl::element
  • updatelistconfig() : uictrl::element
  • updatepositionconfig() : uictrl::element
  • updatestringconfig() : uictrl::element
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Graphe hiérarchique des classes

Graphe hiérarchique des classes

Aller à la hiérarchie des classes en mode texte

Généré le Tue Jan 19 09:44:50 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Index des espaces de nommage

  • Liste des espaces de nommage
  • Membres de l'espace de nommage

Liste des espaces de nommage

Liste de tous les espaces de nommage documentés avec une brève description:
uictrl Portage des fonctions c++ vers python
Généré le Tue Jan 19 09:44:50 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Référence de l'espace de nommage uictrl

  • Liste des espaces de nommage
  • Membres de l'espace de nommage

Référence de l'espace de nommage uictrl

Portage des fonctions c++ vers python. Plus de détails...

Classes

class | application
Classe python de contrôle de I-SIMPA. Plus de détails...
class | e_file
struct | Element
Alias. Plus de détails...
class | element
Contrôle d'un élément implémenté en python ou c++. Plus de détails...

Énumérations

enum element_type {
ELEMENT_TYPE_CORE_ROOT, ELEMENT_TYPE_RESULT_ROOT, ELEMENT_TYPE_SCENE_ROOT, ELEMENT_TYPE_SCENE_PROJET_CONFIGURATION,
ELEMENT_TYPE_SCENE_GROUPESURFACES, ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE, ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE_VERTEX, ELEMENT_TYPE_SCENE_RECEPTEURSP,
ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR, ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_PROPRIETES, ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_RENDU, ELEMENT_TYPE_SCENE_RECEPTEURSS,
ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR, ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_PROPRIETES, ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_RENDU, ELEMENT_TYPE_SCENE_SOURCES,
ELEMENT_TYPE_SCENE_SOURCES_SOURCE, ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PROPRIETES, ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PUISSANCE, ELEMENT_TYPE_SCENE_SOURCES_SOURCE_RENDU,
ELEMENT_TYPE_TEXT, ELEMENT_TYPE_COLOR, ELEMENT_TYPE_POSITION, ELEMENT_TYPE_LIST,
ELEMENT_TYPE_INTEGER, ELEMENT_TYPE_FLOAT, ELEMENT_TYPE_BOOL, ELEMENT_TYPE_SCENE_PROJET_RENDU,
ELEMENT_TYPE_SCENE_PROJET_RENDU_ORIGINE, ELEMENT_TYPE_SCENE_PROJET_RENDU_MODEL, ELEMENT_TYPE_SCENE_BDD, ELEMENT_TYPE_SCENE_BDD_SPECTRUMS,
ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_USER, ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_APP, ELEMENT_TYPE_SCENE_BDD_MATERIAUX, ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP,
ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_GROUP, ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_MATERIAU, ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER, ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_GROUP,
ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_MATERIAU, ELEMENT_TYPE_SCENE_BDD_MATERIAUX_PROPMATERIAU, ELEMENT_TYPE_SCENE_BDD_CATMATERIAL, ELEMENT_TYPE_MATERIAU_APP,
ELEMENT_TYPE_MATERIAU_USER, ELEMENT_TYPE_GAMMEFREQ_APP, ELEMENT_TYPE_GAMMEFREQ_USER, ELEMENT_TYPE_PROPERTY_FREQ,
ELEMENT_TYPE_ROW, ELEMENT_TYPE_ROW_BFREQ, ELEMENT_TYPE_ROW_MATERIAU, ELEMENT_TYPE_SCENE_ENCOMBREMENTS,
ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT, ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_PROPRIETES, ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_CUBOIDE, ELEMENT_TYPE_GAMMEABSORPTION,
ELEMENT_TYPE_CORE_SPPS, ELEMENT_TYPE_CORE_CORE_CONFIG, ELEMENT_TYPE_CORE_CORE_CONFMAILLAGE, ELEMENT_TYPE_SCENE_PROJET,
ELEMENT_TYPE_SCENE_PROJET_USERCONFIGURATION, ELEMENT_TYPE_SCENE_PROJET_RENDU_PARTICULES, ELEMENT_TYPE_SCENE_DONNEES, ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_RENDU,
ELEMENT_TYPE_SCENE_PROJET_ENVIRONNEMENTCONF, ELEMENT_TYPE_DRAWABLE, ELEMENT_TYPE_CORE_CORE_BFREQSELECTION, ELEMENT_TYPE_BOOL_BFREQ,
ELEMENT_TYPE_REPORT_FOLDER, ELEMENT_TYPE_REPORT_PARTVISUALISATION, ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION, ELEMENT_TYPE_REPORT_GABE,
ELEMENT_TYPE_REPORT_GABE_RECP, ELEMENT_TYPE_TREE_LIST, ELEMENT_TYPE_CORE_TC, ELEMENT_TYPE_SCENE_PROJET_INFORMATION,
ELEMENT_TYPE_SCENE_BDD_MATERIAUX_MATERIAU_RENDER, ELEMENT_TYPE_FONT, ELEMENT_TYPE_CORE_TLM, ELEMENT_TYPE_REPORT_GABE_GAP,
ELEMENT_TYPE_REPORT_UNKNOWN, ELEMENT_TYPE_CORE_SPPS_OCTREE, ELEMENT_TYPE_REPORT_RPI, ELEMENT_TYPE_SCENE_VOLUMES,
ELEMENT_TYPE_SCENE_VOLUMES_VOLUME, ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_RENDU, ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_PROPRIETES, ELEMENT_TYPE_PYTHON_EXTENSION,
ELEMENT_TYPE_ELEMENT, ELEMENT_TYPE_CORE_CORE, ELEMENT_TYPE_REPORT_FILE, ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_STANDART,
ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_GAIN, ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_TR, ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_EDT, ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE,
ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_PROPRIETES, ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_RENDU, ELEMENT_TYPE_USER_PREFERENCE_NODE, ELEMENT_TYPE_USER_PREFERENCE_ITEM,
ELEMENT_TYPE_USER_PREFERENCE_ITEM_ISOTEMPLATE
}
enum graph {
GRAPH_FOLDER, GRAPH_ITEM, GRAPH_FOLDER_OPEN, GRAPH_FITTINGS_OPEN,
GRAPH_FITTINGS_CLOSE, GRAPH_FITTING_OPEN, GRAPH_FITTING_CLOSE, GRAPH_PUNCTUAL_RECEIVERS_OPEN,
GRAPH_PUNCTUAL_RECEIVERS_CLOSE, GRAPH_SURFACE_RECEIVERS_OPEN, GRAPH_SURFACE_RECEIVERS_CLOSE, GRAPH_SOUND_SOURCES_OPEN,
GRAPH_SOUND_SOURCES_CLOSE, GRAPH_SURFACES_OPEN, GRAPH_SURFACES_CLOSE, GRAPH_VOLUMES_CLOSE,
GRAPH_VOLUMES_OPEN, GRAPH_PROJECT_OPEN, GRAPH_PROJECT_CLOSE, GRAPH_DATA_CLOSE,
GRAPH_DATA_OPEN, GRAPH_USER_MATERIALS_CLOSE, GRAPH_USER_MATERIALS_OPEN, GRAPH_APPLICATION_MATERIALS_CLOSE,
GRAPH_APPLICATION_MATERIALS_OPEN, GRAPH_DATABASE_CLOSE, GRAPH_DATABASE_OPEN, GRAPH_USER_SPECTRUMS_CLOSE,
GRAPH_USER_SPECTRUMS_OPEN, GRAPH_APPLICATION_SPECTRUMS_CLOSE, GRAPH_APPLICATION_SPECTRUMS_OPEN, GRAPH_MATERIAL_CLOSE,
GRAPH_MATERIAL_OPEN, GRAPH_STANDARTCORE_CLOSE, GRAPH_STANDARTCORE_OPEN, GRAPH_CORES_CLOSE,
GRAPH_CORES_OPEN, GRAPH_SPPSCORE_CLOSE, GRAPH_SPPSCORE_OPEN, GRAPH_DISK_FOLDER_OPEN,
GRAPH_DISK_FOLDER_CLOSE, GRAPH_ENVIRONMENT, GRAPH_PROJECT_AUTHOR, GRAPH_INFORMATION,
GRAPH_DISK_DEFAULT_FILE, GRAPH_DISK_GABE, GRAPH_DISK_RS, GRAPH_DISK_PARTICLE,
GRAPH_EL_CONFIGURATION, GRAPH_EL_3D_DISPLAY, GRAPH_EL_POSITION, GRAPH_EL_TRIANGLE,
GRAPH_SPECTRUM, GRAPH_ORIGIN, GRAPH_TETMESH_PARAMETERS, GRAPH_RENDERING_FOLDER_CLOSE,
GRAPH_RENDERING_FOLDER_OPEN, GRAPH_ROOT_MATERIALS_OPEN, GRAPH_ROOT_MATERIALS_CLOSE, GRAPH_ROOT_SPECTRUMS_OPEN,
GRAPH_ROOT_SPECTRUMS_CLOSE, GRAPH_PUNCTUAL_RECEIVER_OPEN, GRAPH_PUNCTUAL_RECEIVER_CLOSE, GRAPH_SURFACE_RECEIVER_OPEN,
GRAPH_SURFACE_RECEIVER_CLOSE, GRAPH_SOUND_SOURCE_OPEN, GRAPH_SOUND_SOURCE_CLOSE, GRAPH_VOLUME_OPEN,
GRAPH_VOLUME_CLOSE, GRAPH_PREF_ANIMATION, GRAPH_PREF_GENERAL, GRAPH_PREF_LEGEND,
GRAPH_PREF_NOISE_MAP, GRAPH_PREF_PARTICLES, GRAPH_USER_PREF_ROOT_CLOSE, GRAPH_USER_PREF_ROOT_OPEN,
GRAPH_LAST_STATIC_GRAPH
}
enum idevent {
IDEVENT_DELETE_ELEMENT, IDEVENT_RENAME_ELEMENT, IDEVENT_COPIER, IDEVENT_COLLER,
IDEVENT_NEW_SURFACE_GROUP, IDEVENT_GETPROPERTIES, IDEVENT_SELECT_TREE_ITEM, IDEVENT_NEW_RECEPTEUR_P,
IDEVENT_SELECT_POSITION, IDEVENT_NEW_SOURCE, IDEVENT_NEW_RECEPTEUR_S, IDEVENT_NEW_USERFREQ,
IDEVENT_NEW_ENCOMBREMENT, IDEVENT_NEW_ENCOMBREMENT_CUBOIDE, IDEVENT_NEW_USERMAT, IDEVENT_NEW_MATERIAL_GROUP,
IDEVENT_RUN_CALCULATION, IDEVENT_IMPORT_MATERIAL, IDEVENT_LOAD_PARTICLE_SIMULATION, IDEVENT_LOAD_PARTICLE_SIMULATION_PATH,
IDEVENT_RELOAD_FOLDER, IDEVENT_DELETE_FOLDER, IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP, IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP_SUM,
IDEVENT_LOAD_RECEPTEURSS_SIMULATION_SUM, IDEVENT_INVERT_FACE_ORIENTATION, IDEVENT_EMPTY_POINTER_VERTEX_GROUP, IDEVENT_RECP_COMPUTE_ACOUSTIC_PARAMETERS,
IDEVENT_RECEPTEURS_COMPUTE_TR, IDEVENT_RECEPTEURS_COMPUTE_EDT, IDEVENT_REPORT_PARTICULES_MAKE_GABE, IDEVENT_BFREQ_PRESELECTION_NONE,
IDEVENT_BFREQ_PRESELECTION_THIRD_BAND, IDEVENT_BFREQ_PRESELECTION_BAND, IDEVENT_BFREQ_PRESELECTION_BUILDING_THIRD_BAND, IDEVENT_BFREQ_PRESELECTION_BUILDING_BAND,
IDEVENT_RECP_COMPUTE_ADVANCED_ACOUSTIC_PARAMETERS, IDEVENT_NEW_RECEPTEURP_GROUP, IDEVENT_NEW_SOURCE_GROUP, IDEVENT_NEW_SURFACE_GROUP_FROM_SELECTION,
IDEVENT_LOAD_RECEPTEURSP_SIMULATION, IDEVENT_BUILD_VOLUMES_FROM_TRIMESH, IDEVENT_NEW_VOLUME, IDEVENT_OPEN_FOLDER,
IDEVENT_CONVERT_VOL_TO_FITTING, IDEVENT_NEW_RECEPTEUR_S_COUPE, IDEVENT_LAST_FIXED
}

Description détaillée

Portage des fonctions c++ vers python.

Documentation du type de l'énumération

enum uictrl::element_type

Enumeration de tout les types d'élément "built-in" existant

Valeurs énumérées:
ELEMENT_TYPE_CORE_ROOT

Type d'élément

ELEMENT_TYPE_RESULT_ROOT

Type d'élément

ELEMENT_TYPE_SCENE_ROOT

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_CONFIGURATION

Type d'élément

ELEMENT_TYPE_SCENE_GROUPESURFACES

Type d'élément

ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE

Type d'élément

ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE_VERTEX

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSP

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_PROPRIETES

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_RENDU

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_PROPRIETES

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_RENDU

Type d'élément

ELEMENT_TYPE_SCENE_SOURCES

Type d'élément

ELEMENT_TYPE_SCENE_SOURCES_SOURCE

Type d'élément

ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PROPRIETES

Type d'élément

ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PUISSANCE

Type d'élément

ELEMENT_TYPE_SCENE_SOURCES_SOURCE_RENDU

Type d'élément

ELEMENT_TYPE_TEXT

Type d'élément

ELEMENT_TYPE_COLOR

Type d'élément

ELEMENT_TYPE_POSITION

Type d'élément

ELEMENT_TYPE_LIST

Type d'élément

ELEMENT_TYPE_INTEGER

Type d'élément

ELEMENT_TYPE_FLOAT

Type d'élément

ELEMENT_TYPE_BOOL

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_RENDU

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_RENDU_ORIGINE

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_RENDU_MODEL

Type d'élément

ELEMENT_TYPE_SCENE_BDD

Type d'élément

ELEMENT_TYPE_SCENE_BDD_SPECTRUMS

Type d'élément

ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_USER

Type d'élément

ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_APP

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_GROUP

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_MATERIAU

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_GROUP

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_MATERIAU

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_PROPMATERIAU

Type d'élément

ELEMENT_TYPE_SCENE_BDD_CATMATERIAL

Type d'élément

ELEMENT_TYPE_MATERIAU_APP

Type d'élément

ELEMENT_TYPE_MATERIAU_USER

Type d'élément

ELEMENT_TYPE_GAMMEFREQ_APP

Type d'élément

ELEMENT_TYPE_GAMMEFREQ_USER

Type d'élément

ELEMENT_TYPE_PROPERTY_FREQ

Type d'élément

ELEMENT_TYPE_ROW

Type d'élément

ELEMENT_TYPE_ROW_BFREQ

Type d'élément

ELEMENT_TYPE_ROW_MATERIAU

Type d'élément

ELEMENT_TYPE_SCENE_ENCOMBREMENTS

Type d'élément

ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT

Type d'élément

ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_PROPRIETES

Type d'élément

ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_CUBOIDE

Type d'élément

ELEMENT_TYPE_GAMMEABSORPTION

Type d'élément

ELEMENT_TYPE_CORE_SPPS

Type d'élément

ELEMENT_TYPE_CORE_CORE_CONFIG

Type d'élément

ELEMENT_TYPE_CORE_CORE_CONFMAILLAGE

Type d'élément

ELEMENT_TYPE_SCENE_PROJET

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_USERCONFIGURATION

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_RENDU_PARTICULES

Type d'élément

ELEMENT_TYPE_SCENE_DONNEES

Type d'élément

ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_RENDU

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_ENVIRONNEMENTCONF

Type d'élément

ELEMENT_TYPE_DRAWABLE

Element pouvant être représenté dans la vue 3D

ELEMENT_TYPE_CORE_CORE_BFREQSELECTION

Type d'élément

ELEMENT_TYPE_BOOL_BFREQ

Type d'élément

ELEMENT_TYPE_REPORT_FOLDER

Type d'élément

ELEMENT_TYPE_REPORT_PARTVISUALISATION

Type d'élément

ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION

Type d'élément

ELEMENT_TYPE_REPORT_GABE

Type d'élément

ELEMENT_TYPE_REPORT_GABE_RECP

Type d'élément

ELEMENT_TYPE_TREE_LIST

Type d'élément

ELEMENT_TYPE_CORE_TC

Type d'élément

ELEMENT_TYPE_SCENE_PROJET_INFORMATION

Type d'élément

ELEMENT_TYPE_SCENE_BDD_MATERIAUX_MATERIAU_RENDER

Type d'élément

ELEMENT_TYPE_FONT

Type d'élément

ELEMENT_TYPE_CORE_TLM

Type d'élément

ELEMENT_TYPE_REPORT_GABE_GAP

Type d'élément

ELEMENT_TYPE_REPORT_UNKNOWN

Fichier inconnu par PSPS mais connu par le système d'exploitation

ELEMENT_TYPE_CORE_SPPS_OCTREE

Type d'élément

ELEMENT_TYPE_REPORT_RPI

Type d'élément

ELEMENT_TYPE_SCENE_VOLUMES

Type d'élément

ELEMENT_TYPE_SCENE_VOLUMES_VOLUME

Type d'élément

ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_RENDU

Type d'élément

ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_PROPRIETES

Type d'élément

ELEMENT_TYPE_PYTHON_EXTENSION

Type d'élément

ELEMENT_TYPE_ELEMENT

Lors de la déclaration d'un élément utilisateur, ce type permet d'exprimer le fait que l'élément hérite directement de l'élément de base

ELEMENT_TYPE_CORE_CORE

Type d'élément

ELEMENT_TYPE_REPORT_FILE

Type d'élément

ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_STANDART

Type d'élément

ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_GAIN

Type d'élément

ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_TR

Type d'élément

ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_EDT

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_PROPRIETES

Type d'élément

ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_RENDU

Type d'élément

ELEMENT_TYPE_USER_PREFERENCE_NODE

élément de noeud des préférences utilisateurs

ELEMENT_TYPE_USER_PREFERENCE_ITEM

élément des préférences utilisateurs

ELEMENT_TYPE_USER_PREFERENCE_ITEM_ISOTEMPLATE

élément des préférences utilisateurs qui liste les palettes de couleurs iso

enum uictrl::graph

Enumeration des icones déjà chargées

Valeurs énumérées:
GRAPH_FOLDER

Indice d'une image

GRAPH_ITEM

Indice d'une image

GRAPH_FOLDER_OPEN

Indice d'une image

GRAPH_FITTINGS_OPEN

Indice d'une image

GRAPH_FITTINGS_CLOSE

Indice d'une image

GRAPH_FITTING_OPEN

Indice d'une image

GRAPH_FITTING_CLOSE

Indice d'une image

GRAPH_PUNCTUAL_RECEIVERS_OPEN

Indice d'une image

GRAPH_PUNCTUAL_RECEIVERS_CLOSE

Indice d'une image

GRAPH_SURFACE_RECEIVERS_OPEN

Indice d'une image

GRAPH_SURFACE_RECEIVERS_CLOSE

Indice d'une image

GRAPH_SOUND_SOURCES_OPEN

Indice d'une image

GRAPH_SOUND_SOURCES_CLOSE

Indice d'une image

GRAPH_SURFACES_OPEN

Indice d'une image

GRAPH_SURFACES_CLOSE

Indice d'une image

GRAPH_LAST_STATIC_GRAPH

Dernier icône

enum uictrl::idevent

Enumeration des fonctions "built-in" disponibles pour les éléments

Valeurs énumérées:
IDEVENT_DELETE_ELEMENT

Supprime un element

IDEVENT_RENAME_ELEMENT
Paramètres:
{"name",: "new label"} Renommer un élément
IDEVENT_COPIER

Evenement

IDEVENT_COLLER

Evenement

IDEVENT_NEW_SURFACE_GROUP

Evenement

IDEVENT_GETPROPERTIES

Evenement

IDEVENT_SELECT_TREE_ITEM

Evenement

IDEVENT_NEW_RECEPTEUR_P

Evenement

IDEVENT_SELECT_POSITION

Evenement

IDEVENT_NEW_SOURCE

Evenement

IDEVENT_NEW_RECEPTEUR_S

Evenement

IDEVENT_NEW_USERFREQ

Evenement

IDEVENT_NEW_ENCOMBREMENT

Evenement

IDEVENT_NEW_ENCOMBREMENT_CUBOIDE

Evenement

IDEVENT_NEW_USERMAT

Evenement

IDEVENT_NEW_MATERIAL_GROUP

Evenement

IDEVENT_RUN_CALCULATION

Evenement

IDEVENT_IMPORT_MATERIAL
Paramètres:
{"path",: "material file path"} Importer un fichier de matériaux catt ou odeon
IDEVENT_LOAD_PARTICLE_SIMULATION

Evenement

IDEVENT_LOAD_PARTICLE_SIMULATION_PATH

Evenement

IDEVENT_RELOAD_FOLDER

Evenement

IDEVENT_DELETE_FOLDER

Evenement

IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP

Evenement

IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP_SUM

Evenement

IDEVENT_LOAD_RECEPTEURSS_SIMULATION_SUM

Evenement

IDEVENT_INVERT_FACE_ORIENTATION

Evenement inverser l'orientation des faces sélectionnées

IDEVENT_EMPTY_POINTER_VERTEX_GROUP

Evenement vider un pointeur de groupe de surface

IDEVENT_RECP_COMPUTE_ACOUSTIC_PARAMETERS

Evenement calculer les paramètre acoustique d'un recepteur ponctuel

Paramètres:
{"C",: "Clarté (ms)","D":"Définition (ms)","TR":"Décroissance pour le calcul du TR"}
IDEVENT_RECEPTEURS_COMPUTE_TR

Evenement calcul de la cartographie du tr

IDEVENT_RECEPTEURS_COMPUTE_EDT

Evenement calcul de la cartographie de l'edt

IDEVENT_REPORT_PARTICULES_MAKE_GABE

Evenement création du graph niveau sonore en fonction du temps

IDEVENT_BFREQ_PRESELECTION_NONE

Séléction automatique des bandes de fréquences

IDEVENT_BFREQ_PRESELECTION_THIRD_BAND

Séléction automatique des bandes de fréquences

IDEVENT_BFREQ_PRESELECTION_BAND

Séléction automatique des bandes de fréquences

IDEVENT_BFREQ_PRESELECTION_BUILDING_THIRD_BAND

Séléction automatique des bandes de fréquences

IDEVENT_BFREQ_PRESELECTION_BUILDING_BAND

Séléction automatique des bandes de fréquences

IDEVENT_RECP_COMPUTE_ADVANCED_ACOUSTIC_PARAMETERS

Evenement calculer les paramètre acoustique d'un recepteur ponctuel

Paramètres:
{"LF",: "Fraction d'énergie latérale précoce LF (ms)","LFC":"Fraction d'énergie latérale précoce LFC (ms)","LG":"Tenue acoustique latérale LG(ms)","G":"Tenue acoustique G (ms)"}
IDEVENT_NEW_RECEPTEURP_GROUP

Nouveau groupe de récepteur

IDEVENT_NEW_SOURCE_GROUP

Nouveau groupe de sources

IDEVENT_NEW_SURFACE_GROUP_FROM_SELECTION

Nouveau groupe de surface à partir de la sélection

IDEVENT_LOAD_RECEPTEURSP_SIMULATION

Chargement de l'animation des récepteurs ponctuels

IDEVENT_BUILD_VOLUMES_FROM_TRIMESH

Déclaration des volumes à partir du maillage

IDEVENT_NEW_VOLUME

Ajout d'un volume

IDEVENT_OPEN_FOLDER

Ouverture d'un dossier

IDEVENT_CONVERT_VOL_TO_FITTING

Converti le volume en encombrement scène

IDEVENT_NEW_RECEPTEUR_S_COUPE

Ajouter une récepteur en coupe

Généré le Tue Jan 19 09:44:50 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Membres de classe

  • Liste des espaces de nommage
  • Membres de l'espace de nommage
  • Tout
  • Énumérations
  • Valeurs énumérées
  • e
  • g
  • i
Liste de tous les membres des espaces de nommage documentés avec liens vers les espaces de nommage auxquels ils appartiennent :

- e -

  • element_type : uictrl
  • ELEMENT_TYPE_BOOL : uictrl
  • ELEMENT_TYPE_BOOL_BFREQ : uictrl
  • ELEMENT_TYPE_COLOR : uictrl
  • ELEMENT_TYPE_CORE_CORE : uictrl
  • ELEMENT_TYPE_CORE_CORE_BFREQSELECTION : uictrl
  • ELEMENT_TYPE_CORE_CORE_CONFIG : uictrl
  • ELEMENT_TYPE_CORE_CORE_CONFMAILLAGE : uictrl
  • ELEMENT_TYPE_CORE_ROOT : uictrl
  • ELEMENT_TYPE_CORE_SPPS : uictrl
  • ELEMENT_TYPE_CORE_SPPS_OCTREE : uictrl
  • ELEMENT_TYPE_CORE_TC : uictrl
  • ELEMENT_TYPE_CORE_TLM : uictrl
  • ELEMENT_TYPE_DRAWABLE : uictrl
  • ELEMENT_TYPE_ELEMENT : uictrl
  • ELEMENT_TYPE_FLOAT : uictrl
  • ELEMENT_TYPE_FONT : uictrl
  • ELEMENT_TYPE_GAMMEABSORPTION : uictrl
  • ELEMENT_TYPE_GAMMEFREQ_APP : uictrl
  • ELEMENT_TYPE_GAMMEFREQ_USER : uictrl
  • ELEMENT_TYPE_INTEGER : uictrl
  • ELEMENT_TYPE_LIST : uictrl
  • ELEMENT_TYPE_MATERIAU_APP : uictrl
  • ELEMENT_TYPE_MATERIAU_USER : uictrl
  • ELEMENT_TYPE_POSITION : uictrl
  • ELEMENT_TYPE_PROPERTY_FREQ : uictrl
  • ELEMENT_TYPE_PYTHON_EXTENSION : uictrl
  • ELEMENT_TYPE_REPORT_FILE : uictrl
  • ELEMENT_TYPE_REPORT_FOLDER : uictrl
  • ELEMENT_TYPE_REPORT_GABE : uictrl
  • ELEMENT_TYPE_REPORT_GABE_GAP : uictrl
  • ELEMENT_TYPE_REPORT_GABE_RECP : uictrl
  • ELEMENT_TYPE_REPORT_PARTVISUALISATION : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_EDT : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_GAIN : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_STANDART : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_TR : uictrl
  • ELEMENT_TYPE_REPORT_RPI : uictrl
  • ELEMENT_TYPE_REPORT_UNKNOWN : uictrl
  • ELEMENT_TYPE_RESULT_ROOT : uictrl
  • ELEMENT_TYPE_ROW : uictrl
  • ELEMENT_TYPE_ROW_BFREQ : uictrl
  • ELEMENT_TYPE_ROW_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD : uictrl
  • ELEMENT_TYPE_SCENE_BDD_CATMATERIAL : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_GROUP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_MATERIAU_RENDER : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_PROPMATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_GROUP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_APP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_USER : uictrl
  • ELEMENT_TYPE_SCENE_DONNEES : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_CUBOIDE : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE_VERTEX : uictrl
  • ELEMENT_TYPE_SCENE_PROJET : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_CONFIGURATION : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_ENVIRONNEMENTCONF : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_INFORMATION : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_MODEL : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_ORIGINE : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_PARTICULES : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_USERCONFIGURATION : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_ROOT : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PUISSANCE : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_RENDU : uictrl
  • ELEMENT_TYPE_TEXT : uictrl
  • ELEMENT_TYPE_TREE_LIST : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_ITEM : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_ITEM_ISOTEMPLATE : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_NODE : uictrl

- g -

  • graph : uictrl
  • GRAPH_FITTING_CLOSE : uictrl
  • GRAPH_FITTING_OPEN : uictrl
  • GRAPH_FITTINGS_CLOSE : uictrl
  • GRAPH_FITTINGS_OPEN : uictrl
  • GRAPH_FOLDER : uictrl
  • GRAPH_FOLDER_OPEN : uictrl
  • GRAPH_ITEM : uictrl
  • GRAPH_LAST_STATIC_GRAPH : uictrl
  • GRAPH_PUNCTUAL_RECEIVERS_CLOSE : uictrl
  • GRAPH_PUNCTUAL_RECEIVERS_OPEN : uictrl
  • GRAPH_SOUND_SOURCES_CLOSE : uictrl
  • GRAPH_SOUND_SOURCES_OPEN : uictrl
  • GRAPH_SURFACE_RECEIVERS_CLOSE : uictrl
  • GRAPH_SURFACE_RECEIVERS_OPEN : uictrl
  • GRAPH_SURFACES_CLOSE : uictrl
  • GRAPH_SURFACES_OPEN : uictrl

- i -

  • idevent : uictrl
  • IDEVENT_BFREQ_PRESELECTION_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_BUILDING_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_BUILDING_THIRD_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_NONE : uictrl
  • IDEVENT_BFREQ_PRESELECTION_THIRD_BAND : uictrl
  • IDEVENT_BUILD_VOLUMES_FROM_TRIMESH : uictrl
  • IDEVENT_COLLER : uictrl
  • IDEVENT_CONVERT_VOL_TO_FITTING : uictrl
  • IDEVENT_COPIER : uictrl
  • IDEVENT_DELETE_ELEMENT : uictrl
  • IDEVENT_DELETE_FOLDER : uictrl
  • IDEVENT_EMPTY_POINTER_VERTEX_GROUP : uictrl
  • IDEVENT_GETPROPERTIES : uictrl
  • IDEVENT_IMPORT_MATERIAL : uictrl
  • IDEVENT_INVERT_FACE_ORIENTATION : uictrl
  • IDEVENT_LOAD_PARTICLE_SIMULATION : uictrl
  • IDEVENT_LOAD_PARTICLE_SIMULATION_PATH : uictrl
  • IDEVENT_LOAD_RECEPTEURSP_SIMULATION : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP_SUM : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_SUM : uictrl
  • IDEVENT_NEW_ENCOMBREMENT : uictrl
  • IDEVENT_NEW_ENCOMBREMENT_CUBOIDE : uictrl
  • IDEVENT_NEW_MATERIAL_GROUP : uictrl
  • IDEVENT_NEW_RECEPTEUR_P : uictrl
  • IDEVENT_NEW_RECEPTEUR_S : uictrl
  • IDEVENT_NEW_RECEPTEUR_S_COUPE : uictrl
  • IDEVENT_NEW_RECEPTEURP_GROUP : uictrl
  • IDEVENT_NEW_SOURCE : uictrl
  • IDEVENT_NEW_SOURCE_GROUP : uictrl
  • IDEVENT_NEW_SURFACE_GROUP : uictrl
  • IDEVENT_NEW_SURFACE_GROUP_FROM_SELECTION : uictrl
  • IDEVENT_NEW_USERFREQ : uictrl
  • IDEVENT_NEW_USERMAT : uictrl
  • IDEVENT_NEW_VOLUME : uictrl
  • IDEVENT_OPEN_FOLDER : uictrl
  • IDEVENT_RECEPTEURS_COMPUTE_EDT : uictrl
  • IDEVENT_RECEPTEURS_COMPUTE_TR : uictrl
  • IDEVENT_RECP_COMPUTE_ACOUSTIC_PARAMETERS : uictrl
  • IDEVENT_RECP_COMPUTE_ADVANCED_ACOUSTIC_PARAMETERS : uictrl
  • IDEVENT_RELOAD_FOLDER : uictrl
  • IDEVENT_RENAME_ELEMENT : uictrl
  • IDEVENT_REPORT_PARTICULES_MAKE_GABE : uictrl
  • IDEVENT_RUN_CALCULATION : uictrl
  • IDEVENT_SELECT_POSITION : uictrl
  • IDEVENT_SELECT_TREE_ITEM : uictrl
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste alphabétique

Index des classes

A | E
A
E
e_file (uictrl) element (uictrl) Element (uictrl)
application (uictrl)
A | E
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste des membres

uictrl::application Liste des membres

Liste complète des membres de uictrl::application, y compris les membres hérités :
clearlogdata() | uictrl::application | [static]
clearshellhisto() | uictrl::application | [static]
getcachedir() | uictrl::application | [static]
getdataarray(const element &pyel) | uictrl::application | [static]
getlastcalculationpath() | uictrl::application | [static]
getlocale() | uictrl::application | [static]
getrootcore() | uictrl::application | [static]
getrootpreference() | uictrl::application | [static]
getrootreport() | uictrl::application | [static]
getrootscene() | uictrl::application | [static]
getuserinput(const std::string &title, const std::string &msg, boost::python::dict rows) | uictrl::application | [static]
importscene(const std::string &path, bool keepexistingfacegroup=true, bool docorrection=true, bool domeshsurface=false, const std::string &paramTetgen="") | uictrl::application | [static]
loadproject(const std::string &path) | uictrl::application | [static]
newproject() | uictrl::application | [static]
register_event(boost::python::object &func) | uictrl::application | [static]
register_menu_manager(const int &element_typeid, boost::python::object &manager) | uictrl::application | [static]
reloadgroupsfrommodel() | uictrl::application | [static]
savelog(const std::string &path) | uictrl::application | [static]
saveproject(const std::string &path="") | uictrl::application | [static]
saveshell(const std::string &path) | uictrl::application | [static]
sendevent(const element &pyel, const int &idevent, boost::python::dict parameters=boost::python::dict()) | uictrl::application | [static]
Généré le Tue Jan 19 09:44:50 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste des membres

uictrl::e_file Liste des membres

Liste complète des membres de uictrl::e_file, y compris les membres hérités :
appendfilsbytype(Element::ELEMENT_TYPE etypefils, const std::string &libelle="") | uictrl::element |
appendpropertybool(const std::string &propertyName, const std::string &propertyLabel, bool propertyDefaultValue, bool exportToCore=false) | uictrl::element |
appendpropertycolor(const std::string &propertyName, const std::string &propertyLabel, long defaultRed=0, long defaultGreen=0, long defaultBlue=0) | uictrl::element |
appendpropertydecimal(const std::string &propertyName, const std::string &propertyLabel, float propertyDefaultValue=0.f, bool readOnly=false, int precision=4, bool isMaxValue=false, bool isMinValue=false, float maxValue=0, float minValue=0, bool exportToCore=false) | uictrl::element |
appendpropertyentier(const std::string &propertyName, const std::string &propertyLabel, int propertyDefaultValue=0, bool exportToCore=false, bool isMaxValue=false, bool isMinValue=false, int maxValue=0, int minValue=0) | uictrl::element |
appendpropertyfont(const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue="") | uictrl::element |
appendpropertylist(const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &values, long defaultValue, bool asTitle=false, int hSize=1, bool exportToCore=false) | uictrl::element |
appendpropertyposition(const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &propertyDefaultValue, bool exportToCore=false) | uictrl::element |
appendpropertytext(const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue, bool readOnly=false, bool exportToCore=false) | uictrl::element |
appenduserelement(const Element::ELEMENT_TYPE &baseType, const std::string &moduleName, const std::string &className) | uictrl::element |
buildfullpath() | uictrl::e_file |
childs() | uictrl::element |
deleteallelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
deleteallelementbytyper(Element::ELEMENT_TYPE typeElementToDelete) | uictrl::element |
deleteelementbyxmlid(int xmlIdElement, bool setModification=true) | uictrl::element |
e_file(const wxInt32 &_xmlId) (défini dans uictrl::e_file) | uictrl::e_file |
e_file(const element &cpyFrom) (défini dans uictrl::e_file) | uictrl::e_file |
element(const wxInt32 &_xmlId) (défini dans uictrl::element) | uictrl::element |
element(const element &cpyFrom) (défini dans uictrl::element) | uictrl::element |
getallelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
getboolconfig(const std::string &name) | uictrl::element |
getcolorconfig(const std::string &name) | uictrl::element |
getdecimalconfig(const std::string &name) | uictrl::element |
getelementbylibelle(std::string libelle) | uictrl::element |
getelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
getentierconfig(const std::string &name) | uictrl::element |
getid() | uictrl::element | [inline]
getindice() const (défini dans uictrl::element) | uictrl::element |
getinfos() | uictrl::element |
getlistconfig(const std::string &name) | uictrl::element |
getmenu() | uictrl::element |
getpositionconfig(const std::string &name) | uictrl::element |
getstringconfig(const std::string &name) | uictrl::element |
hasproperty(const std::string &name) | uictrl::element |
hide(bool visible=false) | uictrl::element |
modified(int elementUpdated) | uictrl::element |
register_update_manager(boost::python::object &pymethod) | uictrl::element |
setreadonlyallconfig(bool readOnly=true, int col=0) | uictrl::element |
setreadonlyconfig(const std::string &name, bool readOnly=true, int col=0) | uictrl::element |
updateboolconfig(const std::string &name, bool newValue) | uictrl::element |
updatedecimalconfig(const std::string &name, float newValue) | uictrl::element |
updateentierconfig(const std::string &name, int newValue) | uictrl::element |
updatelistconfig(const std::string &name, int newIndex) | uictrl::element |
updatepositionconfig(const std::string &name, const boost::python::list &newValue) | uictrl::element |
updatestringconfig(const std::string &name, const std::string &newValue) | uictrl::element |
xmlId (défini dans uictrl::element) | uictrl::element | [protected]
~element() (défini dans uictrl::element) | uictrl::element | [virtual]
Généré le Tue Jan 19 09:44:52 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste des membres

uictrl::element Liste des membres

Liste complète des membres de uictrl::element, y compris les membres hérités :
appendfilsbytype(Element::ELEMENT_TYPE etypefils, const std::string &libelle="") | uictrl::element |
appendpropertybool(const std::string &propertyName, const std::string &propertyLabel, bool propertyDefaultValue, bool exportToCore=false) | uictrl::element |
appendpropertycolor(const std::string &propertyName, const std::string &propertyLabel, long defaultRed=0, long defaultGreen=0, long defaultBlue=0) | uictrl::element |
appendpropertydecimal(const std::string &propertyName, const std::string &propertyLabel, float propertyDefaultValue=0.f, bool readOnly=false, int precision=4, bool isMaxValue=false, bool isMinValue=false, float maxValue=0, float minValue=0, bool exportToCore=false) | uictrl::element |
appendpropertyentier(const std::string &propertyName, const std::string &propertyLabel, int propertyDefaultValue=0, bool exportToCore=false, bool isMaxValue=false, bool isMinValue=false, int maxValue=0, int minValue=0) | uictrl::element |
appendpropertyfont(const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue="") | uictrl::element |
appendpropertylist(const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &values, long defaultValue, bool asTitle=false, int hSize=1, bool exportToCore=false) | uictrl::element |
appendpropertyposition(const std::string &propertyName, const std::string &propertyLabel, const boost::python::list &propertyDefaultValue, bool exportToCore=false) | uictrl::element |
appendpropertytext(const std::string &propertyName, const std::string &propertyLabel, const std::string &propertyDefaultValue, bool readOnly=false, bool exportToCore=false) | uictrl::element |
appenduserelement(const Element::ELEMENT_TYPE &baseType, const std::string &moduleName, const std::string &className) | uictrl::element |
childs() | uictrl::element |
deleteallelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
deleteallelementbytyper(Element::ELEMENT_TYPE typeElementToDelete) | uictrl::element |
deleteelementbyxmlid(int xmlIdElement, bool setModification=true) | uictrl::element |
element(const wxInt32 &_xmlId) (défini dans uictrl::element) | uictrl::element |
element(const element &cpyFrom) (défini dans uictrl::element) | uictrl::element |
getallelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
getboolconfig(const std::string &name) | uictrl::element |
getcolorconfig(const std::string &name) | uictrl::element |
getdecimalconfig(const std::string &name) | uictrl::element |
getelementbylibelle(std::string libelle) | uictrl::element |
getelementbytype(Element::ELEMENT_TYPE typeElement) | uictrl::element |
getentierconfig(const std::string &name) | uictrl::element |
getid() | uictrl::element | [inline]
getindice() const (défini dans uictrl::element) | uictrl::element |
getinfos() | uictrl::element |
getlistconfig(const std::string &name) | uictrl::element |
getmenu() | uictrl::element |
getpositionconfig(const std::string &name) | uictrl::element |
getstringconfig(const std::string &name) | uictrl::element |
hasproperty(const std::string &name) | uictrl::element |
hide(bool visible=false) | uictrl::element |
modified(int elementUpdated) | uictrl::element |
register_update_manager(boost::python::object &pymethod) | uictrl::element |
setreadonlyallconfig(bool readOnly=true, int col=0) | uictrl::element |
setreadonlyconfig(const std::string &name, bool readOnly=true, int col=0) | uictrl::element |
updateboolconfig(const std::string &name, bool newValue) | uictrl::element |
updatedecimalconfig(const std::string &name, float newValue) | uictrl::element |
updateentierconfig(const std::string &name, int newValue) | uictrl::element |
updatelistconfig(const std::string &name, int newIndex) | uictrl::element |
updatepositionconfig(const std::string &name, const boost::python::list &newValue) | uictrl::element |
updatestringconfig(const std::string &name, const std::string &newValue) | uictrl::element |
xmlId (défini dans uictrl::element) | uictrl::element | [protected]
~element() (défini dans uictrl::element) | uictrl::element | [virtual]
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Membres de classe - Fonctions

  • Tout
  • Fonctions
  • a
  • b
  • c
  • d
  • g
  • h
  • i
  • l
  • m
  • n
  • r
  • s
  • u

- a -

  • appendfilsbytype() : uictrl::element
  • appendpropertybool() : uictrl::element
  • appendpropertycolor() : uictrl::element
  • appendpropertydecimal() : uictrl::element
  • appendpropertyentier() : uictrl::element
  • appendpropertyfont() : uictrl::element
  • appendpropertylist() : uictrl::element
  • appendpropertyposition() : uictrl::element
  • appendpropertytext() : uictrl::element
  • appenduserelement() : uictrl::element

- b -

  • buildfullpath() : uictrl::e_file

- c -

  • childs() : uictrl::element
  • clearlogdata() : uictrl::application
  • clearshellhisto() : uictrl::application

- d -

  • deleteallelementbytype() : uictrl::element
  • deleteallelementbytyper() : uictrl::element
  • deleteelementbyxmlid() : uictrl::element

- g -

  • getallelementbytype() : uictrl::element
  • getboolconfig() : uictrl::element
  • getcachedir() : uictrl::application
  • getcolorconfig() : uictrl::element
  • getdataarray() : uictrl::application
  • getdecimalconfig() : uictrl::element
  • getelementbylibelle() : uictrl::element
  • getelementbytype() : uictrl::element
  • getentierconfig() : uictrl::element
  • getid() : uictrl::element
  • getinfos() : uictrl::element
  • getlastcalculationpath() : uictrl::application
  • getlistconfig() : uictrl::element
  • getlocale() : uictrl::application
  • getmenu() : uictrl::element
  • getpositionconfig() : uictrl::element
  • getrootcore() : uictrl::application
  • getrootpreference() : uictrl::application
  • getrootreport() : uictrl::application
  • getrootscene() : uictrl::application
  • getstringconfig() : uictrl::element
  • getuserinput() : uictrl::application

- h -

  • hasproperty() : uictrl::element
  • hide() : uictrl::element

- i -

  • importscene() : uictrl::application

- l -

  • loadproject() : uictrl::application

- m -

  • modified() : uictrl::element

- n -

  • newproject() : uictrl::application

- r -

  • register_event() : uictrl::application
  • register_menu_manager() : uictrl::application
  • register_update_manager() : uictrl::element
  • reloadgroupsfrommodel() : uictrl::application

- s -

  • savelog() : uictrl::application
  • saveproject() : uictrl::application
  • saveshell() : uictrl::application
  • sendevent() : uictrl::application
  • setreadonlyallconfig() : uictrl::element
  • setreadonlyconfig() : uictrl::element

- u -

  • updateboolconfig() : uictrl::element
  • updatedecimalconfig() : uictrl::element
  • updateentierconfig() : uictrl::element
  • updatelistconfig() : uictrl::element
  • updatepositionconfig() : uictrl::element
  • updatestringconfig() : uictrl::element
Généré le Tue Jan 19 09:44:49 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Légende du graphe

Légende du graphe

Cette page explique comment interpréter les graphes générés par doxygen.

Considérez l'exemple suivant :

/*! Classe invisible à cause d'une troncature */
class Invisible { };

/*! Classe tronquée, la relation d'héritage est masquée */
class Truncated : public Invisible { };

/*! Classe non documentée avec des commentaires Doxygen */
class Undocumented { };

/*! Classe dérivée par héritage public */
class PublicBase : public Truncated { };

/*! Un modèle de classe */
template<class T> class Templ { };

/*! Classe dérivée par héritage protégé */
class ProtectedBase { };

/*! Classe dérivée par héritage privé */
class PrivateBase { };

/*! Classe utilisée par la classe dérivée */
class Used { };

/*! Super-classe qui hérite de plusieurs autres classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

Si la valeur 240 est attribuée au tag MAX_DOT_GRAPH_HEIGHT du fichier de configuration, cela génèrera le graphe suivant :

Les rectangles du graphe ci-dessus ont la signification suivante :

  • Un rectangle plein noir représente la structure ou la classe pour laquelle le graphe est généré.
  • Un rectangle avec un bord noir indique une classe ou une structure documentée.
  • Un rectangle avec un bord gris indique une classe ou une structure non documentée.
  • Un rectangle avec un bord rouge indique une structure ou une classe documentée pour laquelle des relations d'héritage ou de collaboration manquent. Un graphe est tronqué s'il n'entre pas dans les limites spécifiées.

Les flèches ont la signification suivante :

  • Une flèche bleu foncé est utilisée pour visualiser une relation d'héritage public entre deux classes.
  • Une flèche vert foncé est utilisée pour une relation d'héritage protégé.
  • Une flèche rouge foncé est utilisée pour une relation d'héritage privé.
  • Une flèche violette en pointillés est utilisée si une classe est contenue ou utilisée par une autre classe. La flèche est étiquetée avec la ou les variable(s) qui permettent d'accéder à la classe ou structure pointée.
  • Une flèche verte en pointillés indique une relation entre une classe instanciée et le modèle de classe utilisé. La flèche est étiquetée avec les paramètres de modèle de la classe instanciée.
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Membres de classe

  • Liste des espaces de nommage
  • Membres de l'espace de nommage
  • Tout
  • Énumérations
  • Valeurs énumérées
  • element_type : uictrl
  • graph : uictrl
  • idevent : uictrl
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Membres de classe

  • Liste des espaces de nommage
  • Membres de l'espace de nommage
  • Tout
  • Énumérations
  • Valeurs énumérées
  • e
  • g
  • i

- e -

  • ELEMENT_TYPE_BOOL : uictrl
  • ELEMENT_TYPE_BOOL_BFREQ : uictrl
  • ELEMENT_TYPE_COLOR : uictrl
  • ELEMENT_TYPE_CORE_CORE : uictrl
  • ELEMENT_TYPE_CORE_CORE_BFREQSELECTION : uictrl
  • ELEMENT_TYPE_CORE_CORE_CONFIG : uictrl
  • ELEMENT_TYPE_CORE_CORE_CONFMAILLAGE : uictrl
  • ELEMENT_TYPE_CORE_ROOT : uictrl
  • ELEMENT_TYPE_CORE_SPPS : uictrl
  • ELEMENT_TYPE_CORE_SPPS_OCTREE : uictrl
  • ELEMENT_TYPE_CORE_TC : uictrl
  • ELEMENT_TYPE_CORE_TLM : uictrl
  • ELEMENT_TYPE_DRAWABLE : uictrl
  • ELEMENT_TYPE_ELEMENT : uictrl
  • ELEMENT_TYPE_FLOAT : uictrl
  • ELEMENT_TYPE_FONT : uictrl
  • ELEMENT_TYPE_GAMMEABSORPTION : uictrl
  • ELEMENT_TYPE_GAMMEFREQ_APP : uictrl
  • ELEMENT_TYPE_GAMMEFREQ_USER : uictrl
  • ELEMENT_TYPE_INTEGER : uictrl
  • ELEMENT_TYPE_LIST : uictrl
  • ELEMENT_TYPE_MATERIAU_APP : uictrl
  • ELEMENT_TYPE_MATERIAU_USER : uictrl
  • ELEMENT_TYPE_POSITION : uictrl
  • ELEMENT_TYPE_PROPERTY_FREQ : uictrl
  • ELEMENT_TYPE_PYTHON_EXTENSION : uictrl
  • ELEMENT_TYPE_REPORT_FILE : uictrl
  • ELEMENT_TYPE_REPORT_FOLDER : uictrl
  • ELEMENT_TYPE_REPORT_GABE : uictrl
  • ELEMENT_TYPE_REPORT_GABE_GAP : uictrl
  • ELEMENT_TYPE_REPORT_GABE_RECP : uictrl
  • ELEMENT_TYPE_REPORT_PARTVISUALISATION : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_EDT : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_GAIN : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_STANDART : uictrl
  • ELEMENT_TYPE_REPORT_RECEPTEURSSVISUALISATION_TR : uictrl
  • ELEMENT_TYPE_REPORT_RPI : uictrl
  • ELEMENT_TYPE_REPORT_UNKNOWN : uictrl
  • ELEMENT_TYPE_RESULT_ROOT : uictrl
  • ELEMENT_TYPE_ROW : uictrl
  • ELEMENT_TYPE_ROW_BFREQ : uictrl
  • ELEMENT_TYPE_ROW_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD : uictrl
  • ELEMENT_TYPE_SCENE_BDD_CATMATERIAL : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_GROUP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_APP_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_MATERIAU_RENDER : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_PROPMATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_GROUP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_MATERIAUX_USER_MATERIAU : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_APP : uictrl
  • ELEMENT_TYPE_SCENE_BDD_SPECTRUMS_USER : uictrl
  • ELEMENT_TYPE_SCENE_DONNEES : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_CUBOIDE : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_ENCOMBREMENTS_ENCOMBREMENT_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE : uictrl
  • ELEMENT_TYPE_SCENE_GROUPESURFACES_GROUPE_VERTEX : uictrl
  • ELEMENT_TYPE_SCENE_PROJET : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_CONFIGURATION : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_ENVIRONNEMENTCONF : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_INFORMATION : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_MODEL : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_ORIGINE : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_RENDU_PARTICULES : uictrl
  • ELEMENT_TYPE_SCENE_PROJET_USERCONFIGURATION : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSP_RECEPTEUR_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEUR_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_RECEPTEURSS_RECEPTEURCOUPE_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_ROOT : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_PUISSANCE : uictrl
  • ELEMENT_TYPE_SCENE_SOURCES_SOURCE_RENDU : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_PROPRIETES : uictrl
  • ELEMENT_TYPE_SCENE_VOLUMES_VOLUME_RENDU : uictrl
  • ELEMENT_TYPE_TEXT : uictrl
  • ELEMENT_TYPE_TREE_LIST : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_ITEM : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_ITEM_ISOTEMPLATE : uictrl
  • ELEMENT_TYPE_USER_PREFERENCE_NODE : uictrl

- g -

  • GRAPH_FITTING_CLOSE : uictrl
  • GRAPH_FITTING_OPEN : uictrl
  • GRAPH_FITTINGS_CLOSE : uictrl
  • GRAPH_FITTINGS_OPEN : uictrl
  • GRAPH_FOLDER : uictrl
  • GRAPH_FOLDER_OPEN : uictrl
  • GRAPH_ITEM : uictrl
  • GRAPH_LAST_STATIC_GRAPH : uictrl
  • GRAPH_PUNCTUAL_RECEIVERS_CLOSE : uictrl
  • GRAPH_PUNCTUAL_RECEIVERS_OPEN : uictrl
  • GRAPH_SOUND_SOURCES_CLOSE : uictrl
  • GRAPH_SOUND_SOURCES_OPEN : uictrl
  • GRAPH_SURFACE_RECEIVERS_CLOSE : uictrl
  • GRAPH_SURFACE_RECEIVERS_OPEN : uictrl
  • GRAPH_SURFACES_CLOSE : uictrl
  • GRAPH_SURFACES_OPEN : uictrl

- i -

  • IDEVENT_BFREQ_PRESELECTION_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_BUILDING_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_BUILDING_THIRD_BAND : uictrl
  • IDEVENT_BFREQ_PRESELECTION_NONE : uictrl
  • IDEVENT_BFREQ_PRESELECTION_THIRD_BAND : uictrl
  • IDEVENT_BUILD_VOLUMES_FROM_TRIMESH : uictrl
  • IDEVENT_COLLER : uictrl
  • IDEVENT_CONVERT_VOL_TO_FITTING : uictrl
  • IDEVENT_COPIER : uictrl
  • IDEVENT_DELETE_ELEMENT : uictrl
  • IDEVENT_DELETE_FOLDER : uictrl
  • IDEVENT_EMPTY_POINTER_VERTEX_GROUP : uictrl
  • IDEVENT_GETPROPERTIES : uictrl
  • IDEVENT_IMPORT_MATERIAL : uictrl
  • IDEVENT_INVERT_FACE_ORIENTATION : uictrl
  • IDEVENT_LOAD_PARTICLE_SIMULATION : uictrl
  • IDEVENT_LOAD_PARTICLE_SIMULATION_PATH : uictrl
  • IDEVENT_LOAD_RECEPTEURSP_SIMULATION : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_BY_TIMESTEP_SUM : uictrl
  • IDEVENT_LOAD_RECEPTEURSS_SIMULATION_SUM : uictrl
  • IDEVENT_NEW_ENCOMBREMENT : uictrl
  • IDEVENT_NEW_ENCOMBREMENT_CUBOIDE : uictrl
  • IDEVENT_NEW_MATERIAL_GROUP : uictrl
  • IDEVENT_NEW_RECEPTEUR_P : uictrl
  • IDEVENT_NEW_RECEPTEUR_S : uictrl
  • IDEVENT_NEW_RECEPTEUR_S_COUPE : uictrl
  • IDEVENT_NEW_RECEPTEURP_GROUP : uictrl
  • IDEVENT_NEW_SOURCE : uictrl
  • IDEVENT_NEW_SOURCE_GROUP : uictrl
  • IDEVENT_NEW_SURFACE_GROUP : uictrl
  • IDEVENT_NEW_SURFACE_GROUP_FROM_SELECTION : uictrl
  • IDEVENT_NEW_USERFREQ : uictrl
  • IDEVENT_NEW_USERMAT : uictrl
  • IDEVENT_NEW_VOLUME : uictrl
  • IDEVENT_OPEN_FOLDER : uictrl
  • IDEVENT_RECEPTEURS_COMPUTE_EDT : uictrl
  • IDEVENT_RECEPTEURS_COMPUTE_TR : uictrl
  • IDEVENT_RECP_COMPUTE_ACOUSTIC_PARAMETERS : uictrl
  • IDEVENT_RECP_COMPUTE_ADVANCED_ACOUSTIC_PARAMETERS : uictrl
  • IDEVENT_RELOAD_FOLDER : uictrl
  • IDEVENT_RENAME_ELEMENT : uictrl
  • IDEVENT_REPORT_PARTICULES_MAKE_GABE : uictrl
  • IDEVENT_RUN_CALCULATION : uictrl
  • IDEVENT_SELECT_POSITION : uictrl
  • IDEVENT_SELECT_TREE_ITEM : uictrl
Généré le Tue Jan 19 09:44:53 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1


I-SIMPA Scripting Guide: Liste des membres

uictrl::Element Liste des membres

Liste complète des membres de uictrl::Element, y compris les membres hérités :
ELEMENT_TYPE typedef (défini dans uictrl::Element) | uictrl::Element
GRAPH typedef (défini dans uictrl::Element) | uictrl::Element
IDEVENT typedef (défini dans uictrl::Element) | uictrl::Element
Généré le Tue Jan 19 09:44:52 2010 pour I-SIMPA Scripting Guide par doxygen 1.6.1